Closed Bug 665509 Opened 9 years ago Closed 9 years ago

Firefox in dist/bin failed to load any webpage on Solaris after Bug 552864

Categories

(Toolkit :: Startup and Profile System, defect)

x86
Solaris
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla8

People

(Reporter: ginnchen+exoracle, Assigned: ginnchen+exoracle)

References

Details

Attachments

(1 file)

I got error message

WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file /export/home/ginn/work/mozilla-central/toolkit/components/url-classifier/nsUrlClassifierDBService.cpp, line 3873

If I remove the symbolic link of libnssdbm3.so and copy dist/lib/libnssdbm3.so to dist/bin, the problem is gone.

If I set LD_LIBRARY_PATH to dist/bin, the problem is also gone.
(In reply to comment #0)
> If I remove the symbolic link of libnssdbm3.so and copy
> dist/lib/libnssdbm3.so to dist/bin, the problem is gone.

Correction:
Copy libnssdbm3.so and libfreebl3.so to dist/bin/../../nss/softokn solved the problem.

LD_DEBUG log:

27938: 1: dladdr() called from file=/export/home/ginn/work/mozilla-central/debug/dist/bin/libnspr4.so: 0xfe915200
27938: 1: 
27938: 1: file=/export/home/ginn/work/mozilla-central/debug/nss/softokn/libnssdbm3.so;  dlopen() called from file=/export/home/ginn/work/mozilla-central/debug/dist/bin/libnspr4.so  [ RTLD_NOW ]  
27938: 1: 
27938: 1: find object=/export/home/ginn/work/mozilla-central/debug/nss/softokn/libnssdbm3.so; searching
27938: 1:  trying path=/export/home/ginn/work/mozilla-central/debug/nss/softokn/libnssdbm3.so
27938: 1: 
27938: 1: 
27938: 1: ld.so.1: firefox: fatal: /export/home/ginn/work/mozilla-central/debug/nss/softokn/libnssdbm3.so: open failed: No such file or directory
Alternatively, copying the libsoftokn to dist/bin should work, too. I think that would be a proper fix for this.
On Solaris, PR_GetLibraryFilePathname() returns .../obj/nss/softokn/libsoftokn3.so

On Linux, PR_GetLibraryFilePathname() returns .../obj/dist/bin/libsoftokn3.so.

That's why it works on Linux.
Attached patch patchSplinter Review
Assignee: nobody → ginn.chen
Status: NEW → ASSIGNED
Attachment #548105 - Flags: review?(mh+mozilla)
Comment on attachment 548105 [details] [diff] [review]
patch

Review of attachment 548105 [details] [diff] [review]:
-----------------------------------------------------------------
Attachment #548105 - Flags: review?(mh+mozilla) → review+
http://hg.mozilla.org/mozilla-central/rev/d243ecaed4ad
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla8
You need to log in before you can comment on or make changes to this bug.