Composer->Advanced Property Editor (for all objects): <OK> button doen't work

VERIFIED WONTFIX

Status

()

Core
Editor
P2
major
VERIFIED WONTFIX
18 years ago
17 years ago

People

(Reporter: Elena Kostrygina, Assigned: Charles Manske)

Tracking

Trunk
mozilla0.8
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: BRANCH BUILD ONLY)

(Reporter)

Description

18 years ago
In Composer:
1) Click on <Insert new table or edit selected table's properties> button;
<Insert Table> window appears
2) Click on <Advance edit..> button; <Advanced Property Editor> window appears
3) Edit/delete/add some properties, etc.
4) Click on <OK> button; nothing happends! <Cancel> button works, <X> button
works, <OK> doesn't do anything. It has to close this window the same way <X>
button does it.

Comment 1

18 years ago
wfm 2001012504 win98
reporter which build are you using ?

Comment 2

18 years ago
*** Bug 66568 has been marked as a duplicate of this bug. ***
Changing component to composer and reassigning.
Assignee: kmcclusk → beppe
Component: Compositor → Editor
QA Contact: petersen → sujay

Comment 4

18 years ago
using the build 2001012504 on win32, I cannot duplicate this problem. I inserted 
a table (4x4), then selected within a cell, seelcted the cell properties, 
selected advanced edit, and entered the align attribute, selected 'Add' and then 
selected 'OK' -- it worked fine.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 5

18 years ago
we have a problem here...I'm using a 10/25 branch build
and I see the problem...This is problematic on all object
dialogs...this must have regressed cause I thought we fixed
this? I even verified this bug a few days ago.

On 1/25 trunk build it is also busted.

I also tried both themes...busted for both.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Summary: Composer->Advanced Property Editor (for tables): <OK> button doen't work → Composer->Advanced Property Editor (for all objects): <OK> button doen't work

Comment 6

18 years ago
and you're doing this on win98? mac? win95 -- what? Specifically, what steps are 
you doing to get this to happen

Comment 7

18 years ago
Yes, Win 98, Mac and linux using 1/25 branch and trunk builds...all you do is:

1) launch netscape
2) launch composer(any skin)
3) insert any object
4) bring up the dialog for that object by either double-clicking
   on the object ur pull it down from menus
5) click on Advanced Edit button
6) click on "OK"

nothing happens. the dialog doesn't close.

Comment 8

18 years ago
inserted table, dialog works fine
inserted image, dialog works fine
inserted anchor, dialog works fine
inserted HR, dialog works fine
inserted image, dialog works fine

when dialogs are displayed, selected advanced edit, then selected cancel and 
then ok on main dialog -- each worked fine

displayed dialog again, selected advanced edit, changed a value, selected ok and 
selected ok on main dialog -- each worked fine

displayed dialog again, selected advanced edit, inserted new attribute, selected 
 add, selected ok, then slected ok on main dialog -- each worked fine

it is still a wfm on the trunk build

Comment 9

18 years ago
someone broke the branch build build then, because the trunk works fine. btw, 
the first image insert comment, should have said link

Comment 10

18 years ago
okay tested on the trunk on windows(1/25 build)...it works fine..

we are now testing the branch..

sorry for earlier confusion

Comment 11

18 years ago
confirming based on Sujay's comment
Severity: minor → major
Priority: -- → P2
Whiteboard: BRANCH BUILD ONLY
Target Milestone: --- → mozilla0.8

Comment 12

18 years ago
okay this is definitely a problem on 1/25 branch build. someone
must have broke this.

Comment 13

18 years ago
lets fix this for 6.5
Keywords: nsbeta1

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 14

18 years ago
For branch: the workaround is to click the X in the window to close the dialog.
 I verified that the changes made are saved.

Comment 15

18 years ago
pls ignore my previous comment

Comment 16

18 years ago
sorry for the spam.

I found the following:
1.  If you add an attribute or edit it and then click OK, the window doesn't
close. But, if you press Cancel to close the window, the changes are still made.
(this is what people will logically do when they find that OK isn't working)
2.  However, the above didn't seem to work for remove attribute.
win32 branch.

Comment 17

18 years ago
ok, handing this one over to cmanske
Assignee: beppe → cmanske
(Assignee)

Comment 18

18 years ago
This is fixed on the trunk. We are not going to fix it in branch build.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WONTFIX

Comment 19

18 years ago
verified in 1/30 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.