If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crashes when trying to "commit" comment to the bug report.

VERIFIED WONTFIX

Status

()

Core
DOM: Core & HTML
--
major
VERIFIED WONTFIX
17 years ago
17 years ago

People

(Reporter: Navin Gupta, Assigned: Javier Delgadillo)

Tracking

({dom0})

Trunk
mozilla0.9
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
IsChildOfDomWindow(nsIDOMWindow * 0x03cac374, nsIDOMWindow * 0x00000000, int * 
0x0012eb88) line 241 + 27 bytes
nsSecureBrowserUIImpl::Notify(nsSecureBrowserUIImpl * const 0x04073678, 
nsIContent * 0x07788450, nsIDOMWindowInternal * 0x06a55ab4, nsIURI * 0x077ba1e0, 
int * 0x0012ed5c) line 268 + 30 bytes
nsFormFrame::OnSubmit(nsFormFrame * const 0x04e659b8, nsIPresContext * 
0x0709a420, nsIFrame * 0x04ee287c) line 889 + 70 bytes
nsHTMLButtonControlFrame::MouseClicked(nsIPresContext * 0x0709a420) line 362
nsHTMLInputElement::HandleDOMEvent(nsHTMLInputElement * const 0x077eadd0, 
nsIPresContext * 0x0709a420, nsEvent * 0x0012f404, nsIDOMEvent * * 0x00000000, 
unsigned int 1, nsEventStatus * 0x0012f788) line 1156
PresShell::HandleEventInternal(nsEvent * 0x0012f404, nsIView * 0x00000000, 
unsigned int 1, nsEventStatus * 0x0012f788) line 4914 + 47 bytes
PresShell::HandleEventWithTarget(PresShell * const 0x07145200, nsEvent * 
0x0012f404, nsIFrame * 0x04ee287c, nsIContent * 0x077eadd0, unsigned int 1, 
nsEventStatus * 0x0012f788) line 4895 + 22 bytes
nsEventStateManager::CheckForAndDispatchClick(nsEventStateManager * const 
0x07858a50, nsIPresContext * 0x0709a420, nsMouseEvent * 0x0012f894, 
nsEventStatus * 0x0012f788) line 1953 + 61 bytes
nsEventStateManager::PostHandleEvent(nsEventStateManager * const 0x07858a58, 
nsIPresContext * 0x0709a420, nsEvent * 0x0012f894, nsIFrame * 0x04ee287c, 
nsEventStatus * 0x0012f788, nsIView * 0x0776cbf0) line 1080 + 28 bytes
PresShell::HandleEventInternal(nsEvent * 0x0012f894, nsIView * 0x0776cbf0, 
unsigned int 1, nsEventStatus * 0x0012f788) line 4934 + 43 bytes
PresShell::HandleEvent(PresShell * const 0x07145204, nsIView * 0x0776cbf0, 
nsGUIEvent * 0x0012f894, nsEventStatus * 0x0012f788, int 0, int & 1) line 4849 + 
25 bytes
nsView::HandleEvent(nsView * const 0x0776cbf0, nsGUIEvent * 0x0012f894, unsigned 
int 8, nsEventStatus * 0x0012f788, int 0, int & 1) line 379
nsView::HandleEvent(nsView * const 0x07768630, nsGUIEvent * 0x0012f894, unsigned 
int 8, nsEventStatus * 0x0012f788, int 0, int & 1) line 352
nsView::HandleEvent(nsView * const 0x07145930, nsGUIEvent * 0x0012f894, unsigned 
int 28, nsEventStatus * 0x0012f788, int 1, int & 1) line 352
nsViewManager2::DispatchEvent(nsViewManager2 * const 0x07145b10, nsGUIEvent * 
0x0012f894, nsEventStatus * 0x0012f788) line 1537
HandleEvent(nsGUIEvent * 0x0012f894) line 68
nsWindow::DispatchEvent(nsWindow * const 0x077684f4, nsGUIEvent * 0x0012f894, 
nsEventStatus & nsEventStatus_eIgnore) line 687 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012f894) line 708
nsWindow::DispatchMouseEvent(unsigned int 301, nsPoint * 0x00000000) line 3948 + 
21 bytes
ChildWindow::DispatchMouseEvent(unsigned int 301, nsPoint * 0x00000000) line 
4158
nsWindow::ProcessMessage(unsigned int 514, unsigned int 0, long 30670900, long * 
0x0012fc48) line 2965 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x04f00c9a, unsigned int 514, unsigned int 0, long 
30670900) line 922 + 27 bytes
USER32! 77e71820()
Looks like dougt@netscape.com wrote IsChildOfDomWindow(), reassigning. Looks
like a null check is needed.
Assignee: jst → dougt

Comment 2

17 years ago
A null check for the case when the document does not have either a 
ScriptGlobalObject or a nsIDOMWindowInternal.

naving@netscape.com, how can I reproduce this? 
(Reporter)

Comment 3

17 years ago
Try to add a comment to the bug report and hit commit

Updated

17 years ago
Target Milestone: --- → mozilla0.9
Keywords: dom0

Comment 4

17 years ago
to the owner of psm-glue.
Assignee: dougt → bryner
I think this should go to javi.
Assignee: bryner → javi
(Assignee)

Comment 6

17 years ago
How does one reproduce this?
(Assignee)

Comment 7

17 years ago
This is a psm-glue bug which is only used by PSM 1.  We now use PSM 2, so
marking this WONTFIX
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Comment 8

17 years ago
VERIFIED wontfix
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.