[ACR] Automatically detect the version of the application to disable compatibility checks

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Compatibility Tools
P2
normal
RESOLVED WONTFIX
7 years ago
2 years ago

People

(Reporter: whimboo, Assigned: mackers)

Tracking

ACR-0.*
ACR-1.0.3

Details

Updating the list of preferences to disable the compatibility checks for each specific version of the application is time consuming and will end-up in a huge list of preferences, as long as we do not remove old ones.

We should better automatically detect the version of Firefox and set such prefs automatically. With that code we never would have to worry again to update those prefs for a new application version.

The only problem I can see here, where would we have to inject this code? It probably already has to happen during start-up so we do not disable add-ons for the compatibility check. Dave, do you have an idea?

Comment 1

7 years ago
(In reply to comment #0)
> The only problem I can see here, where would we have to inject this code? It
> probably already has to happen during start-up so we do not disable add-ons
> for the compatibility check. Dave, do you have an idea?

Note we already require a 2nd restart for incompatible add-ons to be enabled. See bug 572322.
Assignee: nobody → briks.si
Priority: -- → P2
Target Milestone: --- → ACR-1.0
Version: unspecified → ACR-0.*
I talk about compatibility checks between application version changes, not for the first time ACR gets installed.
I can't really think of a way to make this work. By design extensions shouldn't be able to do anything till the extension manager has finished its work, by which point it is too late to make the changes you want without a restart.

I guess one option for automatic updates would be to check the update manager on shutdown and see if a new update is pending and set the pref at that point.

Made a comment in bug 572322 for something I just remembered

Updated

6 years ago
Assignee: briks.si → dave

Comment 4

6 years ago
I don't think this is relevant anymore. We don't set prefs anymore in compat-by-default builds, and our hard-coded prefs cover all builds up to then.
(Assignee)

Comment 5

6 years ago
Yes, there is no need to address this anymore as there will be no more extensions.checkCompatibility.x prefs.

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX

Updated

6 years ago
Target Milestone: ACR-1.0 → ACR-1.0.3
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.