Frequent timeouts in test_replay_metadata.html, test_seek.html, test_seek_out_of_range.html and test_timeupdate_small_files.html followed by a "4 test timeouts, giving up"

RESOLVED FIXED in mozilla8

Status

()

Core
Audio/Video
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: philor, Unassigned)

Tracking

({intermittent-failure})

Trunk
mozilla8
x86
Linux
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [test which aborts the suite])

(Reporter)

Description

6 years ago
We've been calling this various other things, including bug 573161 and the individual bugs for the last three tests, mostly because we'll do anything to avoid filing an orange bug, but since these four together are timing out five or six times a day, and these four together did not time out five or six (or one) time a day before very recently, I think this is something new, not something old.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1308698734.1308703315.29594.gz
Rev3 Fedora 12 mozilla-central debug test mochitests-1/5 on 2011/06/21 16:25:34
s: talos-r3-fed-024

66485 INFO TEST-PASS | /tests/content/media/test/test_replay_metadata.html | Should have at least one playing event for 320x240.ogv
--DOMWINDOW == 574 (0x1088d638) [serial = 2129] [outer = (nil)] [url = http://mochi.test:8888/tests/content/media/test/test_readyState.html]
--DOMWINDOW == 573 (0xd713060) [serial = 2130] [outer = (nil)] [url = http://mochi.test:8888/tests/content/media/test/test_referer.html]
before 819200, after 815104, break 09913000
66486 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_replay_metadata.html | Test timed out.
...
66544 INFO TEST-PASS | /tests/content/media/test/test_seek.html | r11025_s16_c1.wav seek test 13: ended must be true - true should equal true
SEEK-TEST: Finished r11025_s16_c1.wav seek test 13
66545 INFO TEST-PASS | /tests/content/media/test/test_seek.html | audio.wav seek test 1: Video currentTime should be around 0.0156235: 0.0156235
66546 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_seek.html | Test timed out.
...
66568 INFO TEST-PASS | /tests/content/media/test/test_seek_out_of_range.html | Should only hit the end once for 320x240.ogv
--DOMWINDOW == 575 (0xfa1fea8) [serial = 2132] [outer = (nil)] [url = http://mochi.test:8888/tests/content/media/test/test_seek.html]
--DOMWINDOW == 574 (0xff53360) [serial = 2133] [outer = (nil)] [url = http://mochi.test:8888/tests/content/media/test/test_seek2.html]
--DOMWINDOW == 573 (0xf685610) [serial = 2134] [outer = (nil)] [url = http://mochi.test:8888/tests/content/media/test/test_seekLies.html]
66569 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_seek_out_of_range.html | Test timed out.
...
66607 INFO TEST-PASS | /tests/content/media/test/test_timeupdate_small_files.html | 320x240.ogv - should see at least one timeupdate: 0.266664
--DOMWINDOW == 579 (0xf58c3d8) [serial = 2137] [outer = (nil)] [url = http://mochi.test:8888/tests/content/media/test/test_source_write.html]
--DOMWINDOW == 578 (0x1078b1f0) [serial = 2136] [outer = (nil)] [url = http://mochi.test:8888/tests/content/media/test/test_source.html]
before 827392, after 823296, break 09913000
66608 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_timeupdate_small_files.html | Test timed out.
66609 ERROR TEST-UNEXPECTED-FAIL | (SimpleTest/TestRunner.js) | 4 test timeouts, giving up.
66610 ERROR TEST-UNEXPECTED-FAIL | (SimpleTest/TestRunner.js) | Skipping 93 remaining tests.
(Reporter)

Comment 1

6 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1308689804.1308694305.21299.gz
(Reporter)

Comment 2

6 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1308677954.1308682390.5623.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1308675224.1308679601.26393.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1308685466.1308690412.5808.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1308673127.1308677348.17281.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1308681116.1308685944.20811.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1308680891.1308685617.19528.gz

Apparently my vague memory of it being All/All wasn't quite right, more like Linux32 debug only.
OS: All → Linux
Hardware: All → x86
Comment hidden (Treeherder Robot)
(Reporter)

Updated

6 years ago
Blocks: 666271
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(In reply to comment #47)
> philor
> http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1309784736.1309790049.
> 16544.gz
> Rev3 Fedora 12 mozilla-central debug test mochitests-1/5 on 2011/07/04
> 06:05:36

This timeout is caused by audio drain not returning on Linux.
Depends on: 623444
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Chris, any ideas on this bug?
This is another instance of alsa not returning when writing audio. It should be resolved by bug 623444, hopefully in the next few weeks.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Depends on: 675839
Fixed by Bug 675839.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla8
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
https://tbpl.mozilla.org/php/getParsedLog.php?id=6254182
https://tbpl.mozilla.org/php/getParsedLog.php?id=6251668
No longer depends on: 623444
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Updated

5 years ago
Keywords: intermittent-failure
(Assignee)

Updated

5 years ago
Whiteboard: [orange][test which aborts the suite] → [test which aborts the suite]
You need to log in before you can comment on or make changes to this bug.