Definition of border overwrites -moz-border-*-colors

RESOLVED FIXED

Status

()

Core
DOM: CSS Object Model
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: Sebastian Zartner, Unassigned)

Tracking

({testcase})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by Bug 713643])

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:5.0) Gecko/20100101 Firefox/5.0
Build Identifier: 

When there's a 'border' property defined for a rule, any -moz-border-*-colors properties are not shown inside the cssText property of a CSSStyleRule object.

Reproducible: Always

Steps to Reproduce:
See the attached test case.


Expected Results:  
Both, 'border' and '-moz-border-*-colors' should be inside the cssText.
(Reporter)

Comment 1

7 years ago
Created attachment 541036 [details]
Test case for bug 666243
This is as-intended.  The 'border' shorthand overwrites the -moz-border-*-colors properties; see discussion in bug 482692.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

7 years ago
I see. Though overwriting '-moz-border-*-colors' with the values of 'border' is causing some side effects.
Imagine you create a style 'border' for a node inside the Style side panel of Firebug. After that you create a '-moz-border-top-colors' style.
What happens: The '-moz-border-top-colors' style just disappears and the user wonders why. This happened to my workmate yesterday and he thought it would be a bug in Firebug.
Maybe the problem here is, that the different border colors are not appearing in the shorthand property 'border'. Note, that the test case described above is working, if you define 'border: 1px solid;' and afterwards 'border-color: blue;'. The result will be 'border: 1px solid blue;'. So that behavior of '-moz-border-*-colors' is inconsistent.
(Reporter)

Comment 4

7 years ago
Created attachment 541612 [details]
Enhanced test case for bug 666243

This is definitely a bug.
I enhanced the test case description to show what I mean.
Attachment #541036 - Attachment is obsolete: true
(Reporter)

Comment 5

7 years ago
Created attachment 541613 [details]
Enhanced test case for bug 666243

The attachment didn't get added as text/html for some reason, so I added it again and manually specified test/html as MIME type.
Attachment #541612 - Attachment is obsolete: true
(Reporter)

Comment 6

7 years ago
Hmm, seems, there is also a bug in Bugzilla when attaching files. Even the manual setting of text/html didn't get recognized. Sorry for that. So just download the file and follow the steps. You will see the problem I described.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 7

7 years ago
David, could you reproduce the problem?

Comment 8

4 years ago
(In reply to Sebastian Zartner from comment #7)
> David, could you reproduce the problem?
Flags: needinfo?(dbaron)
Keywords: testcase
Attachment #541613 - Attachment mime type: text/plain → text/html
Created attachment 8503927 [details]
Test case

I cannot reproduce this issue anymore. I added a new, simplier test case to confirm that.

Sebastian
Attachment #541613 - Attachment is obsolete: true
Flags: needinfo?(dbaron)
This obviously got fixed at some point, so I close this issue.
The serialization doesn't work properly in the case a -moz-border-*-colors property is set, though, which should be addressed by bug 713613.

Sebastian
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago4 years ago
Resolution: --- → FIXED

Comment 11

4 years ago
Thanks. We use WORKSFORME when we d ont know which specific patch/bug fixed the issue
Resolution: FIXED → WORKSFORME

Comment 13

4 years ago
(In reply to David Baron [:dbaron] (UTC-7, busy Oct 7-9) (needinfo? for questions) from comment #12)
> It was fixed by https://hg.mozilla.org/mozilla-central/rev/55e6c2ca07e4

 Bug 713643
Resolution: WORKSFORME → FIXED
Whiteboard: [fixed by Bug 713643]
You need to log in before you can comment on or make changes to this bug.