bookmark file sometimes replaced by default bookmark file

VERIFIED DUPLICATE of bug 54866

Status

SeaMonkey
Bookmarks & History
VERIFIED DUPLICATE of bug 54866
18 years ago
14 years ago

People

(Reporter: kenn, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
mozilla sometimes replaces the user bookmark file with the default bookmark file
on startup. The error cannot be cleanly reproduced but occurs about one
time in every 10 restarts. Possible causes are low memory on startup,
incompatibility with imported netscape 4.x bookmarks or interaction with IE
Favorites. Possible resolution: open requester box before replacing user bookmarks
with defaults.

Comment 1

18 years ago
Reporter what Mozilla Build are you using?
(Reporter)

Comment 2

18 years ago
Mozilla 0.7 release, but the bug seems also to be present in current nightly builds.

I've traced it a little further:
It is caused by the use of a german umlaut (so 8-bit chars) in javascript code
in a bookmark. The result is a ever-growing bookmark file (mine was just
16Mbytes) where the umlaut char is replaced by a really long sequence of ascii
codes 203 202 303 in random order. The bug is either caused by the script engine
or the bookmark component, probably in the read routine. Such a bookmark cannot
be edited or deleted within mozilla.

Example bookmark (from the german leo.org site, this is the dictionar lookup
button):

        <DT><A
HREF="javascript:s=document.getSelection();for(i=0;i<frames.length;i++){s=frames[i].document.getSelection();if(s)break;}if(!s)void(s=prompt('Geben
Sie einen Ausdruck an, der von LEO übersetzt werden soll. Sie können ebenfalls
ein Wort auf einer Webseite markieren, bevor Sie auf LeoDict
klicken.',''));if(s){leow=open('http://dict.leo.org/?client=bookmarklet&search='+escape(s),'LEODict','width=700,height=400,scrollbars=yes,resizable=yes');leow.focus();}"
ADD_DATE="978603249" LAST_VISIT="0" LAST_MODIFIED="0">Leo Dict</A>

Temporary workaround: Edit the netscape 4.0 bookmark file in emacs (notepad does
not work) and replace all ü by ue ä by ae and so on. Then import the bookmark
file into mozilla.

Comment 3

18 years ago
Dupe of 54866. Guess its an improvement since its now replacing bookmarks
instead of letting it grow beyond its means. Reopen if you don't agree.

*** This bug has been marked as a duplicate of 54866 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
mass-verifying Duplicate bugs which haven't changed since 2001.12.31.

set your search string in mail to "CitizenGKar" to filter out these messages.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.