Pressing the Tab key gives focus to the tags with CSS property 'overflow:auto'

RESOLVED WONTFIX

Status

()

Firefox
Keyboard Navigation
RESOLVED WONTFIX
7 years ago
6 years ago

People

(Reporter: xcambar, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

Whenever a page contains a form and one or more tags with the CSS property 'overflow:auto', you expect a press on the Tab key to switch between the form's elements.

In FF4, the focus moves from form elements to overflowed blocks in their order of appearance in the flow of the document.

Reproducible: Always

Steps to Reproduce:
1. Load the example code above in your browser
2. Click on the first form field
3. Press Tab

Actual Results:  
That overflow:auto blocks will gain focus instead of the second input field

Expected Results:  
The second input field should get focus

The behavior is the same in every OS I've put my hands on (Win Vista, Ubuntu 10.04, OSX 10.6)

The workaround provided at http://support.mozilla.com/en-US/kb/Pressing%20Tab%20key%20does%20not%20select%20menus%20or%20buttons
did not work (tried only under Ubuntu 10.04)


Sample code to reproduce:
-------------------------

<input type="text" name="test"/>
<div style="overflow:auto">
    <p style="overflow:auto"><input type="text" name="test"/></p>
</div>
(Reporter)

Comment 1

7 years ago
Created attachment 541074 [details]
Sample code to reproduce the bug

Comment 2

6 years ago
Mozilla/5.0 (X11; Linux i686; rv:8.0a1) Gecko/20110720 Firefox/8.0a1

Focusing the first textfield and pressing the tab key once changes the focus to the second textfield.

Maybe you have some addon installed that blocks this from happening. Can you please try it on a clean profile, just to rule that out:
http://support.mozilla.com/en-US/kb/Managing-profiles
(Reporter)

Comment 3

6 years ago
The bug disappeared in FF5.

Btw, to reproduce my bug, you should've tested it on the same version as mine...

Firefox/4.0.1 VS Firefox/8.0a1 is not a fair game ;)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX

Comment 4

6 years ago
(In reply to comment #3)
> Firefox/4.0.1 VS Firefox/8.0a1 is not a fair game ;)

Looks like it. The Mozilla devs have been keeping busy.
You need to log in before you can comment on or make changes to this bug.