Last Comment Bug 666298 - test_crash_submit.xul fails to run inside mochitest-chrome
: test_crash_submit.xul fails to run inside mochitest-chrome
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Joel Maher (:jmaher)
:
Mentors:
Depends on:
Blocks: 642175
  Show dependency treegraph
 
Reported: 2011-06-22 09:49 PDT by Joel Maher (:jmaher)
Modified: 2011-06-23 13:04 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
remove expectProcessCrash from the chrome test (1.0) (1.17 KB, patch)
2011-06-22 09:57 PDT, Joel Maher (:jmaher)
jmaher: review+
Details | Diff | Review

Description Joel Maher (:jmaher) 2011-06-22 09:49:03 PDT
currently this test passes, but with zero tests run.  This is a side effect of bug 642175.  For now it makes sense to not expect a crash dump and let this test do what it was intended for.  In addition, doing this will work with specialpowers migration in the works.
Comment 1 Joel Maher (:jmaher) 2011-06-22 09:57:50 PDT
Created attachment 541085 [details] [diff] [review]
remove expectProcessCrash from the chrome test (1.0)

ted says r=me for this one liner as per discussion in irc.
Comment 2 Josh Matthews [:jdm] 2011-06-22 12:34:09 PDT
You might want to check if SimpleTest.testPluginIsOOP() is returning true in mochitest-chrome. That's the only reason I can see this running zero tests.
Comment 3 Ted Mielczarek [:ted.mielczarek] 2011-06-22 12:39:02 PDT
It was running zero tests because it was throwing an exception on trying to call expectProcessCrash, which heycam made explicitly throw in chrome.
Comment 4 Cameron McCormack (:heycam) 2011-06-22 14:56:31 PDT
And uncaught exceptions from a chrome mochitest doesn't cause a test failure (bug 652494). :(
Comment 5 Joel Maher (:jmaher) 2011-06-23 13:04:42 PDT
http://hg.mozilla.org/mozilla-central/rev/0542577e3994

Note You need to log in before you can comment on or make changes to this bug.