Old Firefox release notes have poorly labeled link to the latest Firefox download

RESOLVED WONTFIX

Status

www.mozilla.org
Pages & Content
RESOLVED WONTFIX
7 years ago
4 years ago

People

(Reporter: L A Walsh, Unassigned)

Tracking

(Blocks: 2 bugs)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.17) Gecko/20110420 Firefox/3.6.17
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.17) Gecko/20110420 Firefox/3.6.17

I was offered an update for firefox 3.6.18.  I clicked on "more information" to see the release notes -- and got the V3.6.18 release notes, but then when I clicked on the Download 
button, it wanted to download FF 5.0 -- the WRONG version...

This is clearly a bad bug -- someone goes to read release notes, and if not paying attention gets a completely different version than what they are looking at.

Please fix this ASAP....how does one download the update?

I want to download the installer package to be able to install on multiple machines!



Reproducible: Always

Steps to Reproduce:
1.  Get offered update in FF. 
2.  Click on more info  (see rel notes for offered update)..
3. Click on Download button and get offered complete different version to download...

Actual Results:  
Offered wrong version for update.


Expected Results:  
Offered correct version
It is most likely offering your 5.0, because that is the most recent version, 3.6 will be dropped from support soon. Did you click on the download button on the webpage or the upgrade banner?
Component: Migration → General
QA Contact: migration → general
Hardware: All → x86
Version: unspecified → 3.6 Branch
Yep, on http://www.mozilla.com/en-US/firefox/3.6.18/releasenotes/ there's a Download Button pointing to e.g. http://www.mozilla.com/en-US/products/download.html?product=firefox-5.0&os=win&lang=en-US (depending on Locale/OS I presume).

l10n Builds what don't have localized Rel Notes (like de-DE as of now) are redirected to e.g. http://www.mozilla.com/de/firefox/ with a similar Button, but stating the Version more prominent.

Somebody still can simply download the Update within the Software Update Dialog though.

Another Way is clicking "Other Systems and Languages" beyond the Button and on the next Page under "Other Firefox Downloads" on "Firefox 3.6.18".

No Idea if this Process is intended/wanted :-/
Component: General → Migration
QA Contact: general → migration
Hardware: x86 → All
Version: 3.6 Branch → unspecified
Component: Migration → General
QA Contact: migration → general
Version: unspecified → 3.6 Branch
OHHHHHHH I see now. So you clicked the download button on the website, which naturally will take you to the latest Firefox version. Website bug ten most likely.
Component: General → www.mozilla.com
Product: Firefox → Websites
QA Contact: general → www-mozilla-com
Summary: Firefox update process broken → Firefox 3.6.18 release notes have poorly labeled link to Firefox latest download.
Version: 3.6 Branch → other
(Reporter)

Comment 4

7 years ago
FYI, above is correct.... clicked on get-ff on the rel-notes page...

Comment 5

7 years ago
Yeah, this behavior is a bit undefined. On one hand we want users to download the latest build. On the other, if they are looking at release notes for a particular version they probably want to download that version (well, maybe).

I'm not sure I can change it to point to 3.6.18 specifically, it might have to default to the latest old version (3.6.19, which is 3.6.18 + some Mac OS X 10.7 fixes). I'll look into it when I get time, but this is pretty low on the ol' priority list.
(Reporter)

Comment 6

7 years ago
Understood -- but I couldn't find the link to the 'older version' either,

that's what prompted me to write a bug, otherwise might not have felt it sufficiently important.

Comment 7

7 years ago
We only expose the "latest" old version @ http://www.mozilla.com/firefox/all-older.html (and we try not to advertise that, not sure where it is linked from).

For "old" old versions you have to go to ftp.mozilla.org and root around.
Duplicate of this bug: 679996

Updated

6 years ago
Blocks: 679996
(Assignee)

Updated

6 years ago
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
(Assignee)

Updated

5 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org

Updated

5 years ago
Blocks: 813052

Updated

5 years ago
Blocks: 879502

Updated

5 years ago
Duplicate of this bug: 686680

Updated

5 years ago
Severity: major → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Summary: Firefox 3.6.18 release notes have poorly labeled link to Firefox latest download. → Old Firefox release notes have poorly labeled link to the latest Firefox download

Updated

4 years ago
Component: General → Pages & Content
Version: other → unspecified
This page has been archived and no longer updated.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.