Closed Bug 666357 Opened 9 years ago Closed 9 years ago

Offered locale picker with Japanese Android OS locale

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: aaronmt, Unassigned)

References

Details

Mozilla/5.0 (Android; Linux armv7l; rv:7.0a1) Gecko/20110622 Firefox/7.0a1 Fennec/7.0a1

Currently when Japanese (日本語) is selected as the Android OS locale, on first-run the browser will present the locale picker (in English), when it should not. Opting to continue in English will start the browser in Japanese (日本語) as it should.

I have not tried any other locales.

STR:

1. Set your device (via Language and Keyboard settings) to use Japanese (日本語)
2. Start Nightly with a new profile. 

ER: Nightly omits the locale selector and starts in Japanese (日本語).

AR: Nightly presents the locale selector and offers to start the browser in English. Upon starting, Japanese (日本語) is the current locale.
The locale selector should not a) be visible, and b) not offer to opt a English profile locale and then start in the device locale.
Flags: in-litmus?(aaron.train)
I quick look at the ja XPI shows the localepicker.properties have not been translated, so you are seeing the en-US strings. This is an l10n "bug" in that the strings need to be translated.

I think I'll close this and we'll wait for the ja localizers to finish.

http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-linux-l10n/
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
Unable to reproduce what I thought I saw earlier where available languages in both the system and in Fennec would permit a bypass of the locale picker (but not Japanese), but such is not the case.

Yes, ja should be localized for the locale picker.
Flags: in-litmus?(aaron.train)
Blocks: 689706
You need to log in before you can comment on or make changes to this bug.