Typing alias into URL bar now redirects to unexpected domain

RESOLVED INVALID

Status

()

Firefox
Address Bar
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: martinez248, Unassigned)

Tracking

5 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0) Gecko/20100101 Firefox/5.0
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0) Gecko/20100101 Firefox/5.0

Before I upgraded to Firefox 5.0 I used to be able to type the alias ("mylc") of my internally hosted web server into the URL bar and it would resolve correctly.  Now when I type "mylc" into the URL bar it redirects me to www.mylc.com.  Firefox 4.0 and below work fine, it's only Firefox 5.0 that is causing this issue.

Reproducible: Always

Steps to Reproduce:
1. Setup DNS alias for internal web server
2. Type alias into url bar
3.

Actual Results:  
Redirects to incorrect domain www.<alias>.com

Expected Results:  
Should've redirected to the resolved domain for the "mylc" alias

Updated

7 years ago
Version: unspecified → 5 Branch
(Reporter)

Comment 1

7 years ago
As it turns out this is not a browser issue, but a server side issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.