Last Comment Bug 666481 - jsatom.cpp:945:12: warning: variable ‘count’ set but not used
: jsatom.cpp:945:12: warning: variable ‘count’ set but not used
Status: RESOLVED FIXED
[build_warning][fixed-in-tracemonkey]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th)
:
Mentors:
Depends on:
Blocks: 385729
  Show dependency treegraph
 
Reported: 2011-06-22 19:14 PDT by Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th)
Modified: 2011-06-27 11:38 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (1.08 KB, patch)
2011-06-22 19:19 PDT, Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th)
igor: review+
Details | Diff | Splinter Review

Description Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th) 2011-06-22 19:14:05 PDT
gcc-4.6 reports this build warning:
js/src/jsatom.cpp: In function ‘void js_InitAtomMap(JSContext*, JSAtomMap*, JSAtomList*)’:
js/src/jsatom.cpp:945:12: warning: variable ‘count’ set but not used [-Wunused-but-set-variable]

Bug 385729 removed the last usages of this variable 'count'[1], but left the variable there.  It looks like this variable can just go away.

[1] Lines 1.156 & 1.161 of http://hg.mozilla.org/mozilla-central/diff/5db593415bf1/js/src/jsatom.c#l1.156
Comment 1 Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th) 2011-06-22 19:19:46 PDT
Created attachment 541262 [details] [diff] [review]
fix
Comment 2 Igor Bukanov 2011-06-23 02:35:20 PDT
Comment on attachment 541262 [details] [diff] [review]
fix

Review of attachment 541262 [details] [diff] [review]:
-----------------------------------------------------------------

That is a nice feature of GCC 4.6!
Comment 3 Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th) 2011-06-23 02:49:27 PDT
http://hg.mozilla.org/tracemonkey/rev/4f1eb9b43658
Comment 4 Chris Leary [:cdleary] (not checking bugmail) 2011-06-27 11:38:11 PDT
cdleary-bot mozilla-central merge info:
http://hg.mozilla.org/mozilla-central/rev/4f1eb9b43658

Note You need to log in before you can comment on or make changes to this bug.