The background of an embedded PNG in swf is not transparent

RESOLVED INVALID

Status

Tamarin
Virtual Machine
--
critical
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Joey Che, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2)
Build Identifier: 10.3.181.26

Embed a PNG in swf use DefineBitsJPEG3 tag (use mx image component to display the PNG), which background is transparent in Flash Player 10.2.152.26 and earlier versions. But it doesn't work properly on Flash Player 10.3.181.26.

Reproducible: Always

Steps to Reproduce:
1.Open attached swf in browser or standalone Flash Player, the background of PNG
is not transparent.

Actual Results:  
The background of PNG in swf is not transparent.

Expected Results:  
The background of PNG in swf should be transparent.
(Reporter)

Comment 1

7 years ago
Created attachment 541326 [details]
The swf to reproduce this transparent issue.

The swf to reproduce this transparent issue.
This is very unlikely to be a virtual machine bug.

Joey: you probably want to file it on bugs.adobe.com

I suspect it could be a duplicate of this bug, so perhaps you should provide your test case there after reading the comments on it:

  https://bugs.adobe.com/jira/browse/SDK-8877

Comment 3

7 years ago
This is not a Tamarin VM issue.  As Felix noted, you can file Player bugs on bugs.adobe.com.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.