If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

toolbar=no, location=no, status=no, menubar=no, etc ignored when CNN page is loading

VERIFIED DUPLICATE of bug 66527

Status

SeaMonkey
UI Design
VERIFIED DUPLICATE of bug 66527
17 years ago
9 years ago

People

(Reporter: hirata masakazu, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
The Quickpoll in this URL should be displayed in a popup window that does not
have toolbar etc as specified in its script.
Result: Clicking the Vote button or clicking the View results link brings up a
new window complete with items supposedly disabled.
2001012510MTrunk.
May be related to bug 66527?

Comment 1

17 years ago
Browser, not engine. Reassigning to XP Apps: GUI Features component -
Assignee: rogerl → ben
Component: Javascript Engine → XP Apps: GUI Features
QA Contact: pschwartau → sairuh
Summary: toolbar=no, location=no, status=no, menubar=no, etc ignored → toolbar=no, location=no, status=no, menubar=no, etc ignored

Comment 2

17 years ago
Using Mozilla binaries 20010125xx on WinNT, 20010126xx on Linux, Mac.


When I tried to vote at http://www.cnn.com  (see "Quick Vote" near bottom),
I kept getting timed out. So I couldn't see the bug there -


Then I tried the link "View Results". This came up on all three platforms
without a toolbar, etc.; exactly as NN4.7 does it. 


I would like to mark this WORKSFORME. But could someone else try the
voting procedure? I keep getting timed out on it - 
(Reporter)

Comment 3

17 years ago
It is now working in 2001012608 MTrunk build.
That was a quick fix wasn't it?
Marking WFM.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

17 years ago
Well, not so quick.
I am still seeing this behavior under certain conditions.
It is hard to nail down because www.cnn.com causes hangs in recent builds quite
often.
(Reporter)

Comment 5

17 years ago
There seems to be some networking issue involved with this bug.
www.cnn.com causes Mozilla to load forever, with the throbber turning.
When this is happening, the Vote button brings up a new window rather than a
popup window defined by the javascript.
Furthermore, under such circumstances, "view results" link next to the Vote
button and other popup links in this URL do not work at all.
The working example can be found anywhere the page finishes loading normally. An
example is www.boston.com 's picture gallery.

This bug is not present in 2001012204 MTrunk build. You can get the popup while
throbber is moving at www.cnn.com. Still seen in 2001012608 build.
Reopening with modified summary.
Severity: major → normal
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: toolbar=no, location=no, status=no, menubar=no, etc ignored → toolbar=no, location=no, status=no, menubar=no, etc ignored when CNN page is loading
(Reporter)

Comment 6

17 years ago
I am owndering if this one shares a problem in Javascript bug 66527.
In 020108MTrunk, I never get the proper popup window even after loading of the
page seems complete.
(Reporter)

Comment 7

17 years ago
It is highly likely that this is a dupe of bug 66527, since both have JS defined
in <script src=URL>.
I am duping this to 66527,since defining JS within the page restored
functionality just like 66527. 

*** This bug has been marked as a duplicate of 66527 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
mass verification of duplicate bugs: to find all bugspam pertaining to this, set
your search string to "DuplicateBugsBelongInZahadum".

if you think this particular bug is *not* a duplicate, please provide a
compelling reason, as well as check a recent *trunk* build (on the appropriate
platform[s]), before reopening.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.