crash in ImgDCallbk::CreateInstance

VERIFIED WORKSFORME

Status

()

Core
ImageLib
--
critical
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: Jens-Uwe, Assigned: pnunn)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.14 i686; en-US; m18) Gecko/20010125
BuildID:    2001012506

mozilla crashes on this page. It did not crash just a few days ago, I guess this
is a regression.

Reproducible: Always
Steps to Reproduce:
1. go to www.amdzone.com
2. wait a moment
3. see mozilla crashes


Actual Results:  mozilla crashes

Expected Results:  it should not crash

AMDzone is mentioned in Bug 63344, but it seems not to be related. I also did
not have this problem until very recently, so it is probably a regrassion. 
below you can find the stack trace:

Document http://www.amdzone.com/ loaded successfully

Program received signal SIGSEGV, Segmentation fault.
0x40035d92 in ImgDCallbk::CreateInstance () from
/home/jur/ftp/test/testmoz/mozilla/libgkgfx.so
(gdb) where
#0  0x40035d92 in ImgDCallbk::CreateInstance () from
/home/jur/ftp/test/testmoz/mozilla/libgkgfx.so
#1  0x40036b32 in IL_DestroyImage () from
/home/jur/ftp/test/testmoz/mozilla/libgkgfx.so
#2  0x4002df44 in ImageRequestImpl::~ImageRequestImpl () from
/home/jur/ftp/test/testmoz/mozilla/libgkgfx.so
#3  0x4002e121 in ImageRequestImpl::Release () from
/home/jur/ftp/test/testmoz/mozilla/libgkgfx.so
#4  0x40becfea in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/libgklayout.so
#5  0x40c01cd7 in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/libgklayout.so
#6  0x40a2a295 in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/libgklayout.so
#7  0x40a2a2f0 in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/libgklayout.so
#8  0x40b9141d in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/libgklayout.so
#9  0x40b915b8 in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/libgklayout.so
#10 0x40a1ca0d in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/libgklayout.so
#11 0x40a23521 in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/libgklayout.so
#12 0x40a23b19 in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/libgklayout.so
#13 0x40a23b19 in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/libgklayout.so
#14 0x40a23c84 in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/libgklayout.so
#15 0x40b15dc7 in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/libgklayout.so
#16 0x40c1b969 in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/libgklayout.so
#17 0x40a46b9f in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/libgklayout.so
#18 0x407ff125 in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/librdf.so
#19 0x407ef10d in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/librdf.so
#20 0x407eb2d3 in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/librdf.so
#21 0x403ab12e in NS_NewScriptDocumentType () from
/home/jur/ftp/test/testmoz/mozilla/libjsdom.so
#22 0x40128f15 in js_Invoke () from /home/jur/ftp/test/testmoz/mozilla/libmozjs.so
#23 0x401302c5 in js_Interpret () from
/home/jur/ftp/test/testmoz/mozilla/libmozjs.so
#24 0x40128f60 in js_Invoke () from /home/jur/ftp/test/testmoz/mozilla/libmozjs.so
#25 0x40749d4b in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/libxpconnect.so
#26 0x407486f5 in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/libxpconnect.so
#27 0x400d94f4 in XPTC_InvokeByIndex () from
/home/jur/ftp/test/testmoz/mozilla/libxpcom.so
#28 0x400d9606 in nsXPTCStubBase::Stub7 () from
/home/jur/ftp/test/testmoz/mozilla/libxpcom.so
#29 0x40dd2014 in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/libmozbrwsr.so
#30 0x40989896 in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/liburiloader.so
#31 0x40988fba in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/liburiloader.so
#32 0x40988e76 in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/liburiloader.so
#33 0x40988d3b in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/liburiloader.so
#34 0x40884f7e in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/libnecko.so
#35 0x408b3988 in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/libnecko.so
#36 0x408ba4f5 in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/libnecko.so
#37 0x4087c2d6 in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/libnecko.so
#38 0x4087c1cc in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/libnecko.so
#39 0x400c7503 in PL_HandleEvent () from
/home/jur/ftp/test/testmoz/mozilla/libxpcom.so
#40 0x400c7426 in PL_ProcessPendingEvents () from
/home/jur/ftp/test/testmoz/mozilla/libxpcom.so
#41 0x400c81e9 in nsEventQueueImpl::ProcessPendingEvents () from
/home/jur/ftp/test/testmoz/mozilla/libxpcom.so
#42 0x40480dbf in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/libwidget_gtk.so
#43 0x40480b7d in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/libwidget_gtk.so
#44 0x40633340 in g_io_unix_dispatch (source_data=0x81ca008,
current_time=0xbffff220, user_data=0x81df4c8) at giounix.c:135
#45 0x40634bd6 in g_main_dispatch (dispatch_time=0xbffff220) at gmain.c:656
#46 0x40635203 in g_main_iterate (block=1, dispatch=1) at gmain.c:877
#47 0x406353cc in g_main_run () at gmain.c:884
#48 0x4055400c in gtk_main () at gtkmain.c:807
#49 0x404812ac in NSGetModule () from
/home/jur/ftp/test/testmoz/mozilla/components/libwidget_gtk.so
#50 0x4042ecaa in inflate_mask () from
/home/jur/ftp/test/testmoz/mozilla/components/libnsappshell.so
#51 0x804dd55 in JS_PushArguments ()
#52 0x804e5b5 in JS_PushArguments ()
#53 0x4024aa5e in __libc_start_main () at ../sysdeps/generic/libc-start.c:93
(Reporter)

Comment 1

18 years ago
seems to work with build 2001012906. 
(Reporter)

Comment 2

18 years ago
after getting some additional WORKSFORME comments on IRC, I mark this as
WORKSFORME. 
whoever might have fixed it...
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 3

18 years ago
Hmmm... I'm crashing on the http://www.amdzone.com/ all the times using the same
nightlies. The difference is my operating system (RH Linux 7.0 with latest
updates included). I've tried the same nightly on my colleague computer with RH
6.2 and there it doesn't crash.
(Reporter)

Comment 4

18 years ago
tom:
do you have plug ins installed. If yes, can you for testing purposes remove them
and try this page again? 
Here it crashes, if I have the libflashplayer.so in my plug in directory, I get
a crash in libgfx in todays linux build (2001013121).

Comment 5

18 years ago
No, I don't have any plugins installed (except for null plugin from the default
install). I don't even get the null plugin's dialog box for getting the flash
player installed, because the mozilla crashes before that.

Comment 6

18 years ago
Wow! I've finally updated my gdb to version which can run mozilla. So I have
backtrace of the bug and it is definitely a different bug. So this should stay
RESOLVED WORKSFORME. Apparently the crash I'm seeing is a dup of the bug 60381.

Comment 7

17 years ago
Marking as VERIFIED since I am not crashing on the site anymore.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.