SessionStore history serialized too early

VERIFIED FIXED in Firefox 7

Status

VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: mfinkle, Assigned: mfinkle)

Tracking

Trunk
Firefox 7
Dependency tree / graph

Details

(Whiteboard: QA?)

Attachments

(1 attachment)

Created attachment 541368 [details] [diff] [review]
patch

Bug 604463 serialized the session history in OnLocationChange, but that is a bit too early. It causes two problems:

* The "title" of the current page was not ready and therefore never saved. about:home skips entries without titles when building the list of "tabs from last time" so no tabs were shown.
* serializing a lot of session history in the middle of a pageload (onLocationChange) causes a pageload slowdown. We need to delay the serialization to improve pageload speed

This patch:
* Moves session history serialization / deserialization to WebNavigation so it's all in one place
* Sends the serialized history after a DOMContentLoaded message, giving the page more time to finish loading
* Fixes a problem in about:home where the session history index was not being used to show the tab from last time
Attachment #541368 - Flags: review?(mbrubeck)
Blocks: 666564
Comment on attachment 541368 [details] [diff] [review]
patch

My main concern was that this might wait *too* long to save session history, and regress bug 630398.  But it looks like this goes back to using the DOMContentLoaded event, which is the same place where we used to save session history before bug 604463 landed.
Attachment #541368 - Flags: review?(mbrubeck) → review+
Assignee: nobody → mark.finkle
Blocks: 604463
OS: Linux → All
Hardware: x86 → All
Whiteboard: [inbound]
http://hg.mozilla.org/mozilla-central/rev/1800c8a42d0b
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 7
Whiteboard: [inbound]

Comment 3

8 years ago
Steps to reproduce:

1. Open a few tabs 
2. In one tab, visit more than website and the use the "back" arrow.
3. Close the application

The list from "Tabs from last time" is right 
"Tabs from last time" from about:home shows you the right title - not the "forward"-most title in the session history

VERIFIED FIXED on:

Build ID: Mozilla /5.0 (Android;Linux armv7l;rv:7.0a2) Gecko/20110713 Firefox/7.0a2 Fennec/7.0a2 

Device: HTC Desire Z (Android 2.2)
Status: RESOLVED → VERIFIED

Updated

7 years ago
Whiteboard: QA?
You need to log in before you can comment on or make changes to this bug.