Closed Bug 666581 Opened 10 years ago Closed 10 years ago

Firefox 7.0a1 20110622 update snippets are broken

Categories

(Release Engineering :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: unghost, Assigned: coop)

References

Details

Firefox 7.0a1 20110622 fails to download update:

AUS:SVC getLocale - getting locale from file: /opt/firefox/update.locale, locale: ru
AUS:SVC Checker:getUpdateURL - update URL: https://aus3.mozilla.org/update/3/Firefox/7.0a1/20110622030844/Linux_x86-gcc3/ru/nightly/Linux%202.6.38-10-generic%20(GTK%202.24.4)/default/default/update.xml?force=1
AUS:SVC gCanCheckForUpdates - able to check for updates
AUS:SVC Checker:checkForUpdates - sending request to: https://aus3.mozilla.org/update/3/Firefox/7.0a1/20110622030844/Linux_x86-gcc3/ru/nightly/Linux%202.6.38-10-generic%20(GTK%202.24.4)/default/default/update.xml?force=1
AUS:SVC Checker:onLoad - request completed downloading document
AUS:SVC Checker:getUpdateURL - update URL: https://aus3.mozilla.org/update/3/Firefox/7.0a1/20110622030844/Linux_x86-gcc3/ru/nightly/Linux%202.6.38-10-generic%20(GTK%202.24.4)/default/default/update.xml?force=1
AUS:SVC Checker:onLoad - number of updates available: 1
AUS:SVC gCanApplyUpdates - testing write access /opt/firefox/update.test
AUS:SVC gCanApplyUpdates - able to apply updates
AUS:SVC readStringFromFile - file doesn't exist: /opt/firefox/updates/0/update.status
AUS:SVC readStatusFile - status: null, path: /opt/firefox/updates/0/update.status
AUS:SVC Downloader:downloadUpdate - downloading from http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011/06/2011-06-23-03-mozilla-central-l10n/firefox-7.0a1.ru.linux-i686.partial.20110622030844-20110623030811.mar to /opt/firefox/updates/0/update.mar
AUS:SVC Downloader:onStartRequest - original URI spec: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011/06/2011-06-23-03-mozilla-central-l10n/firefox-7.0a1.ru.linux-i686.partial.20110622030844-20110623030811.mar, final URI spec: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011/06/2011-06-23-03-mozilla-central-l10n/firefox-7.0a1.ru.linux-i686.partial.20110622030844-20110623030811.mar
AUS:SVC Downloader:onStopRequest - original URI spec: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011/06/2011-06-23-03-mozilla-central-l10n/firefox-7.0a1.ru.linux-i686.partial.20110622030844-20110623030811.mar, final URI spec: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011/06/2011-06-23-03-mozilla-central-l10n/firefox-7.0a1.ru.linux-i686.partial.20110622030844-20110623030811.mar, status: 2147549183
AUS:SVC Downloader:onStopRequest - non-verification failure
AUS:SVC getStatusTextFromCode - transfer error: Failed (unknown reason), default code: 2152398849
AUS:SVC Downloader:onStopRequest - setting state to: download-failed
AUS:SVC Downloader:onStopRequest - verification of patch failed, downloading complete update patch
AUS:SVC readStringFromFile - file doesn't exist: /opt/firefox/updates/0/update.status
AUS:SVC readStatusFile - status: null, path: /opt/firefox/updates/0/update.status
AUS:SVC Downloader:_selectPatch - found existing patch with state: null
AUS:SVC Downloader:downloadUpdate - downloading from http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011/06/2011-06-23-03-mozilla-central-l10n/firefox-7.0a1.ru.linux-i686.complete.mar to /opt/firefox/updates/0/update.mar
AUS:SVC Downloader:onStartRequest - original URI spec: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011/06/2011-06-23-03-mozilla-central-l10n/firefox-7.0a1.ru.linux-i686.complete.mar, final URI spec: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011/06/2011-06-23-03-mozilla-central-l10n/firefox-7.0a1.ru.linux-i686.complete.mar
AUS:SVC Downloader:onStopRequest - original URI spec: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011/06/2011-06-23-03-mozilla-central-l10n/firefox-7.0a1.ru.linux-i686.complete.mar, final URI spec: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011/06/2011-06-23-03-mozilla-central-l10n/firefox-7.0a1.ru.linux-i686.complete.mar, status: 2147549183
AUS:SVC Downloader:onStopRequest - non-verification failure
AUS:SVC getStatusTextFromCode - transfer error: Failed (unknown reason), default code: 2152398849
AUS:SVC Downloader:onStopRequest - setting state to: download-failed
AUS:SVC Downloader:onStopRequest - all update patch downloads failed

Looks like the reason of failure that path to mar file in snippet is http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011/06/2011-06-23-03-mozilla-central-l10n/ but correct path to mar file is http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011/06/2011-06-23-03-08-11-mozilla-central-l10n/ (perhaps due Bug 449607)
Depends on: 449607
Duplicate of this bug: 666561
This is also reproducible on aurora channel :)
Duplicate of this bug: 666602
Assignee: nobody → coop
This looks fixed to me. I was able to update my nightly just fine.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
(In reply to comment #4)
> This looks fixed to me. I was able to update my nightly just fine.

Yes, I've updated the affected snippets to point to the new, correct directory location. The snippet automation change in bug 449607 should fix this permanently.
Status: RESOLVED → VERIFIED
Mine still won't update.  I'm still getting the same behavior, I get prompted for an update, I hit OK, it says it's downloading it, and then there's no progress meter and the download never happens.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Maybe I missed a window and the new day's build went up and had the wrong snippets again?  (just taking a wild guess)
Dave, could you set the pref app.update.log to true, then restart your browser. You should be able to get the AUS query (https://aus3.mozilla.org/....) from the Error Console then, after opening the About dialog to force an update check.
https://aus2.mozilla.org/update/4/Fennec/7.0a1/20110621041703/Android_arm-eabi-gcc3/en-US/nightly/Linux%202.6.35.10-gc0a661b/default/default/7.0a1/update.xml?force=1

It appears to successfully get a download URL from that, it tries to download:
http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/2011/06/2011-06-23-04-mozilla-central-android/fennec-7.0a1.multi.eabi-arm.apk

after it says it's downloading, we have these log entries:

AUS:SVC Downloader:onStopRequest - non-verification failure
AUS:SVC getStatusTextFromCode - transfer error: Failed (unknown reason), default code: 2152398849
AUS:SVC Downloader:onStopRequest - setting state to: download-failed
And trying that download URL manually, I get a 404.
I suspect only the Firefox snippets got fixed then. The best thing to do is wait for the next set of nightlies, which should work by way of the patch on bug 449607.
This is still reproducing for updates from 6/23 to 6/24
(In reply to comment #12)
> This is still reproducing for updates from 6/23 to 6/24

What branch/platform? Some nightlies are still in progress (e.g. aurora) and the snippets that are in place have the correct update URL.
(In reply to comment #11)
> I suspect only the Firefox snippets got fixed then. The best thing to do is
> wait for the next set of nightlies, which should work by way of the patch on
> bug 449607.

I updated these snippets, but forgot to touch the dirs for Fennec (like I did for Firefox) so the update system would register the change.
(In reply to comment #13)
> (In reply to comment #12)
> > This is still reproducing for updates from 6/23 to 6/24
> 
> What branch/platform? Some nightlies are still in progress (e.g. aurora) and
> the snippets that are in place have the correct update URL.

Nightly and Aurora branch, build ids:
 Mozilla /5.0 (Android;Linux armv7l;rv:7.0a1) Gecko/20110623 Firefox/7.0a1 Fennec/7.0a1 
and 
 Mozilla /5.0 (Android;Linux armv7l;rv:6.0a2) Gecko/20110623 Firefox/6.0a2 Fennec/1.0a2 
don't update to 6/24 build.
(In reply to comment #15) 
> Nightly and Aurora branch, build ids:
>  Mozilla /5.0 (Android;Linux armv7l;rv:7.0a1) Gecko/20110623 Firefox/7.0a1
> Fennec/7.0a1 
> and 
>  Mozilla /5.0 (Android;Linux armv7l;rv:6.0a2) Gecko/20110623 Firefox/6.0a2
> Fennec/1.0a2 
> don't update to 6/24 build.

Snippets should be correct now. Try again?

There's a separate script generating Android snippets. Attachment 541678 [details] [diff] should resolve this for tomorrow.
I still can't update on Android.  I'm guessing the separate script mentioned in comment 16 means I still need to wait till tomorrow.
(In reply to comment #17)
> I still can't update on Android.  I'm guessing the separate script mentioned
> in comment 16 means I still need to wait till tomorrow

Yes, in short, snippet should be correct tomorrow. However, I did also find two Android snippets from this morning that were pointing to the wrong dir (from before I found the issue). These have also been fixed now.
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
verified fixed.  My Evo updated itself successfully this afternoon.
Status: RESOLVED → VERIFIED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.