Closed Bug 666614 Opened 9 years ago Closed 6 years ago

xpcom/io/nsLocalFileUnix.cpp - compiler warnings

Categories

(Core :: XPCOM, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 786118

People

(Reporter: joey, Unassigned)

Details

(Whiteboard: [build_warning])

/mozilla/sandbox/gml/xpcom/io/nsLocalFileUnix.cpp:307: warning: 'stat64' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/usr/include/sys/stat.h:465)
/mozilla/sandbox/gml/xpcom/io/nsLocalFileUnix.cpp:307: warning: 'stat64' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/usr/include/sys/stat.h:465)
/mozilla/sandbox/gml/xpcom/io/nsLocalFileUnix.cpp:309: warning: 'lstat64' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/usr/include/sys/stat.h:464)
/mozilla/sandbox/gml/xpcom/io/nsLocalFileUnix.cpp:309: warning: 'lstat64' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/usr/include/sys/stat.h:464)
/mozilla/sandbox/gml/xpcom/io/nsLocalFileUnix.cpp:1039: warning: 'lstat64' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/usr/include/sys/stat.h:464)
/mozilla/sandbox/gml/xpcom/io/nsLocalFileUnix.cpp:1039: warning: 'lstat64' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/usr/include/sys/stat.h:464)
/mozilla/sandbox/gml/xpcom/io/nsLocalFileUnix.cpp:1078: warning: 'lstat64' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/usr/include/sys/stat.h:464)
/mozilla/sandbox/gml/xpcom/io/nsLocalFileUnix.cpp:1078: warning: 'lstat64' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/usr/include/sys/stat.h:464)
/mozilla/sandbox/gml/xpcom/io/nsLocalFileUnix.cpp:1172: warning: 'lstat64' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/usr/include/sys/stat.h:464)
/mozilla/sandbox/gml/xpcom/io/nsLocalFileUnix.cpp:1172: warning: 'lstat64' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/usr/include/sys/stat.h:464)
/mozilla/sandbox/gml/xpcom/io/nsLocalFileUnix.cpp:1464: warning: 'lstat64' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/usr/include/sys/stat.h:464)
/mozilla/sandbox/gml/xpcom/io/nsLocalFileUnix.cpp:1464: warning: 'lstat64' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/usr/include/sys/stat.h:464)
/mozilla/sandbox/gml/xpcom/io/nsLocalFileUnix.cpp:1536: warning: 'lstat64' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/usr/include/sys/stat.h:464)
/mozilla/sandbox/gml/xpcom/io/nsLocalFileUnix.cpp:1536: warning: 'lstat64' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/usr/include/sys/stat.h:464)
/mozilla/sandbox/gml/xpcom/io/nsLocalFileUnix.cpp:1582: warning: 'lstat64' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/usr/include/sys/stat.h:464)
/mozilla/sandbox/gml/xpcom/io/nsLocalFileUnix.cpp:1582: warning: 'lstat64' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/usr/include/sys/stat.h:464)
% uname -a
Darwin banshee.local 10.7.4 Darwin Kernel Version 10.7.4: Mon Apr 18 21:24:17 PDT 2011; root:xnu-1504.14.12~3/RELEASE_X86_64 x86_64
Whiteboard: [build_warnings]
Whiteboard: [build_warnings] → [build_warning]
Forward duping to Bug 786118 as it has a r+ patch attached.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 786118
No longer blocks: buildwarning
You need to log in before you can comment on or make changes to this bug.