Last Comment Bug 666665 - Remove isindex content code
: Remove isindex content code
Status: RESOLVED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla8
Assigned To: :Ms2ger
:
Mentors:
Depends on: 664061
Blocks: 674310
  Show dependency treegraph
 
Reported: 2011-06-23 11:17 PDT by :Ms2ger
Modified: 2011-07-29 03:50 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (23.17 KB, patch)
2011-06-23 11:17 PDT, :Ms2ger
jonas: review+
hsivonen: review+
Details | Diff | Review

Description :Ms2ger 2011-06-23 11:17:22 PDT
Created attachment 541439 [details] [diff] [review]
Patch v1
Comment 1 Jonas Sicking (:sicking) PTO Until July 5th 2011-06-23 22:15:14 PDT
Comment on attachment 541439 [details] [diff] [review]
Patch v1

>From: Ms2ger <ms2ger@gmail.com>
>
>diff --git a/content/base/src/nsGkAtomList.h b/content/base/src/nsGkAtomList.h
>--- a/content/base/src/nsGkAtomList.h
>+++ b/content/base/src/nsGkAtomList.h
>@@ -474,17 +474,16 @@ GK_ATOM(insertafter, "insertafter")
> GK_ATOM(insertbefore, "insertbefore")
> GK_ATOM(instanceOf, "instanceOf")
> GK_ATOM(int32, "int32")
> GK_ATOM(int64, "int64")
> GK_ATOM(integer, "integer")
> GK_ATOM(intersection, "intersection")
> GK_ATOM(iscontainer, "iscontainer")
> GK_ATOM(isempty, "isempty")
>-GK_ATOM(isindex, "isindex")

Don't know if the HTML5 parser might need (or befit from) this. r=me if Henri signs off on this too.
Comment 2 Henri Sivonen (:hsivonen) 2011-06-24 00:06:51 PDT
Comment on attachment 541439 [details] [diff] [review]
Patch v1

Removing this is OK. For the time being, the HTML5 parser makes an "isindex" atom exist by other means.
Comment 4 :Ms2ger 2011-07-29 03:17:57 PDT
For documentation, note that we haven't created nsIDOMHTMLIsIndexElements since bug 611352. Checks for "node instanceof nsIDOMHTMLIsIndexElement" can be replaced with "node instanceof nsIDOMHTMLInputElement".
Comment 5 Kris Maglione [:kmag] 2011-07-29 03:50:41 PDT
Added notes to Firefox 8 release notes. The interface is not documented elsewhere on MDC.

https://developer.mozilla.org/en/Firefox_8_for_developers#section_2

Note You need to log in before you can comment on or make changes to this bug.