break up history component

VERIFIED FIXED

Status

()

bugzilla.mozilla.org
Administration
VERIFIED FIXED
18 years ago
7 years ago

People

(Reporter: Alec Flett, Assigned: asa)

Tracking

Details

(Reporter)

Description

18 years ago
We need to break up the Browser's history component into
History: Session - owned by radha@netscape.com
This is the back/forward history for a particular browsing session. This
includes bugs in HTML frame navigation and the navigator.history object.

History: Global - owned by alecf@netscape.com
This is the global history which tracks all URLs that a user has visited, across
all sessions of the browser. This also includes the history window and link
coloring.

History: URLBar - owned by alecf@netscape.com
This is the type-in history for the URL bar in the browser window. This includes
behavior of the autocomplete widget for URLs, as well as the storage and
expiration of the entries.
(Reporter)

Comment 1

18 years ago
I should mention that ideally current History component should be renamed to the
"History: Session" (since most of the History bugs are probably Session History)
and then radha and I will reassign the Global and URLBar bugs to their
appropriate components.
(Reporter)

Comment 2

18 years ago
*** Bug 66695 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

18 years ago
that dupe has Examples for the descriptions.

Comment 4

18 years ago
Done.  I've used the descriptions which alec describes here.  I will go now to
add the examples described by vishy in the other bug.   History was renamed to
History: Session and the other history components were added.

See http://bugzilla.mozilla.org/editcomponents.cgi?product=Browser.  Expect the
examples to show up in the descriptions in about 5 minutes.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

18 years ago
coolness! thanks lisa
Status: RESOLVED → VERIFIED
(Assignee)

Comment 6

18 years ago
Thanks lchiang.
Component: Bugzilla: Keywords & Components → Administration
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.