If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

table width is rendered wrong in Mozilla .7, happens with a mix of div, tables, and forms. This page works properly in Mozilla .6 (also NN4+ and IE4,IE5)

RESOLVED FIXED

Status

SeaMonkey
General
RESOLVED FIXED
17 years ago
13 years ago

People

(Reporter: Garick Hamlin, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.18 i686; en-US; 0.6) Gecko/20001205
BuildID:    Mozilla .7 (does not happen in .6)

Example at devel.reckittimages.com.
This page uses tables to align images and form elements for compatability with
NN4.  It also uses DIVs for Roll-over effects.
The table renders fine on Mozilla .6 on Linux, haven't tested elsewhere on .7
the bug appears.  One div appears to get rendered inside the table instead of
above, however "shadows" of form elements appear when you mouse over where the
table elements should be.  Reload makes things look even stranger.

Reproducible: Always
Steps to Reproduce:
This page always misrenders.  Haven't looked for a minimium subset
of these tags to show bug.

devel.reckittimages.com

Actual Results:  Tables render with big blocks of white where there should be no
inline
element forms elements appear to be partially rendered in two differnet places
on the page, and a reload looks slightly different.

Expected Results:  Tables should be render w/o extra whitespace.  Forms elements
should not have these "ghosts".  Button rollovers should line-up
with images underneatch

Comment 1

17 years ago
Reporter please try with tha latest nightly:
http://ftp.mozilla.org/pub/mozilla/nightly/latest/
It seams to render ok here.

Mozilla 2001012420 on Windows 2000 SP1 on PC.
(Reporter)

Comment 2

17 years ago
Works 20010112521 on Linux.
Looks like its been fixed.

Thanks


Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.