Mozilla 0.7 fails MathML 2 testsuite (mi token)

VERIFIED WONTFIX

Status

()

Core
MathML
VERIFIED WONTFIX
17 years ago
17 years ago

People

(Reporter: Anand Kumria, Assigned: rbs)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.17 i686; en-US; 0.7) Gecko/20010112
BuildID:    2001011217

Mozilla 0.7 fails the following MathML 2 tests:

mi2, mi3, mi4, miAtoken5, miScolorname6, miScolorscope7, miSfonts8,
miSfontsize9, miStoken10, miequivalents11 (particularly bad, affects
internationalisation), mifontstyle12, mimathvarient13

Reproducible: Always
Steps to Reproduce:
1. Go to the above URL; on the left will be a frame containing all
the test
2. I've mentioned in the description which ones have failed
3. go to test and see sample rendering and then see what Mozilla does

Actual Results:  Mozilla 0.7 doesn't have any of the entities as far as I can see

Expected Results:  Available on the testsuite webpage

Comment 1

17 years ago
Confirmed for Linux build 2001012806.

Reporter, you should probably break this bug up into multiple bugs, and
then use this bug as a tracking bug by making this bug depend on all the
others.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

17 years ago
The problem is that all these tests are served with the text/html MIME type, and
so are treated as HTML documents by Mozilla (not XHTML/XML documents). Hence the
MathML engine doesn't even get called to handle the <math>...</math> fragments
that are in the MathML namespace.

Resolving as WONTFIX because there isn't much that can be done at this end.
See however bug 67646 where I am suggesting that files with the .xhtml extension
be treated as XML files by Mozilla.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
Yup, text/html all the way. VERIFIED WONTFIX.

It's ironic that the two options that the W3C make available in their test
suite are both invalid (one uses entities with no DTD, and the other sends
XML using the text/html MIME type, which the HTML working group have told us
is not right). Do the relevant people know about this?
Status: RESOLVED → VERIFIED
QA Contact: py8ieh=bugzilla → ian
You need to log in before you can comment on or make changes to this bug.