Deleting tabs in succession doesn't work when scroll buttons are present in the tab strip.

RESOLVED DUPLICATE of bug 649654

Status

()

enhancement
RESOLVED DUPLICATE of bug 649654
8 years ago
6 years ago

People

(Reporter: vlad.ghetiu, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

8 years ago
Mozilla/5.0 (Windows NT 6.1; rv:7.0a1) Gecko/20110623 Firefox/7.0a1

Deleting tabs in succession doesn't work when scroll buttons are present in the tab strip.

Step to reproduce:

1. Start Firefox and open some blank tabs until the scroll buttons appear in the tab strip.
2. Select first tab from the strip and begin closing the tabs from the "x" button until the scroll buttons disappear. 

Actual results:
When the scroll buttons disappear, the whole strip is resized leaving the "x" button of the tab not focused by the mouse cursor anymore, meaning that you have to move the mouse in order to continue closing the tabs. 

Expected results:
You should be able to delete all the tabs continuously. 

Not resizing the tabs until you move the mouse off the tabbar is a great thing and in my opinion the scroll buttons must have the same behavior. The buttons must disappear only when you move the mouse off the tabstrip.
Severity: normal → enhancement
Hardware: x86 → All

Updated

8 years ago
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 465086

Comment 2

8 years ago
Ack, copied wrong bug number. My bad.
Duplicate of bug: 649654
Reporter

Comment 3

8 years ago
This is not a duplicate because it's not the same behavior.
The tabs are not resized when you delete them but the tab bar is. See actual results from description.
IMO this is a bug. The tabs are not resized for one reason so they can be all closed in succession. I found that they are not closing as expected, so this is a bug.

Comment 4

8 years ago
(In reply to comment #3)

I read the description. It is a duplicate. The scroll buttons themselves do not have to remain. Instead, the space they take up should persist until mouseout. When I land the fix for bug 649654, you'll see what I mean.
A dependency might be a clearer way to indicate that; "handle more gracefully" and "feature broken" aren't really the same at all. Or maybe bug 649654 just needs a better summary.
You need to log in before you can comment on or make changes to this bug.