Last Comment Bug 666938 - No warning when Binary XPCOMs fail loading due to Module::kVersion
: No warning when Binary XPCOMs fail loading due to Module::kVersion
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Benjamin Smedberg [:bsmedberg]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-24 08:14 PDT by Jerry Krinock
Modified: 2011-06-28 18:56 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Console message for kVersion mismatch, rev. 1 (5.53 KB, patch)
2011-06-24 11:14 PDT, Benjamin Smedberg [:bsmedberg]
dtownsend: review+
Details | Diff | Review

Description Jerry Krinock 2011-06-24 08:14:16 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_8; en-us) AppleWebKit/533.21.1 (KHTML, like Gecko) Version/5.0.5 Safari/533.21.1
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0) Gecko/20100101 Firefox/5.0

Starting with Firefox 5.0, binary XPCOM components must have exactly the correct Module::kVersion or they will not load.  Since this will happen with any extension containing such a component that has not been updated recently, this should not be a silent failure.  There should be at least a warning printed to the system stderr or Firefox' Error Console

Reproducible: Always

Steps to Reproduce:
1.  Install an older Firefox extension containing a Binary XPCOM Component into Firefox 5.
2.  Launch Firefox 5 and do whatever is needed to load the extension.

Actual Results:  
Error console prints only a warning saying that the XPCOM Component is undefined.

Expected Results:  
Error console, and probably system's stderr, should instead print a warning explaining that there was a mismatch in Module::kVersion, giving the required kVersion and the found kVersion, with a recovery suggestion to update the extension and a link to the documentation further explaining the issue.

For more information, see this bug

https://bugzilla.mozilla.org/show_bug.cgi?id=656331
Comment 1 Benjamin Smedberg [:bsmedberg] 2011-06-24 11:14:32 PDT
Created attachment 541725 [details] [diff] [review]
Console message for kVersion mismatch, rev. 1
Comment 2 Joe Drew (not getting mail) 2011-06-28 18:56:53 PDT
http://hg.mozilla.org/mozilla-central/rev/3b245f7f94d7

Note You need to log in before you can comment on or make changes to this bug.