Linking XPT files fails for Windows 64-bit's XulRunner

RESOLVED DUPLICATE of bug 661910

Status

defect
RESOLVED DUPLICATE of bug 661910
8 years ago
Last year

People

(Reporter: armenzg, Unassigned)

Tracking

Trunk
x86
macOS
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

8 years ago
Linking XPT files...
d:/mozilla-build/python/python2.6.exe /e/builds/moz2_slave/cen-w64-xr/build/config/optimizejars.py --optimize /e/builds/moz2_slave/cen-w64-xr/build/obj-firefox/xulrunner/installer/../../jarlog//en-US ../../dist/bin/chrome ../../dist/xulrunner/chrome
Removing unpackaged files...
cd ../../dist/xulrunner; rm -rf xulrunner-config regchrome* regxpcom*  core bsdecho gtscc js js-config jscpucfg nsinstall viewer TestGtkEmbed codesighs* elf-dynstr-gc mangle* maptsv* mfc* mkdepend* msdump* msmap* nm2tsv* nsinstall* res/samples res/throbber shlibsign* ssltunnel* certutil* pk12util* winEmbed.exe chrome/chrome.rdf chrome/app-chrome.manifest chrome/overlayinfo components/compreg.dat components/xpti.dat content_unit_tests necko_unit_tests *.dSYM 
e:/builds/moz2_slave/cen-w64-xr/build/obj-firefox/config/nsinstall.exe -D ../../dist/
Compressing...
cd ../../dist && (cd xulrunner && rm -f omni.jar components/binary.manifest && grep -h '^binary-component' components/*.manifest > binary.manifest ; sed -e 's/^binary-component/#binary-component/' components/components.manifest > components.manifest && mv components.manifest components && zip -r9m omni.jar chrome chrome.manifest components/*.js components/*.xpt components/*.manifest modules res defaults greprefs.js jsloader  -x chrome/icons/\* defaults/pref/channel-prefs.js res/cursors/\* res/MainMenu.nib/\*  && true && d:/mozilla-build/python/python2.6.exe /e/builds/moz2_slave/cen-w64-xr/build/config/optimizejars.py --optimize /e/builds/moz2_slave/cen-w64-xr/build/obj-firefox/xulrunner/installer/../../jarlog//en-US ./ ./ && mv binary.manifest components && printf "manifest components/binary.manifest\n" > chrome.manifest) && (cd xulrunner && d:/mozilla-build/python/python2.6.exe /e/builds/moz2_slave/cen-w64-xr/build/config/createprecomplete.py) && zip -r9D xulrunner-7.0a1.en-US.win64-x86_64.zip xulrunner
make[2]: Leaving directory `/e/builds/moz2_slave/cen-w64-xr/build/obj-firefox/xulrunner/installer'
sed: can't read components/components.manifest: No such file or directory
make[2]: *** [make-package] Error 2
make[1]: Leaving directory `/e/builds/moz2_slave/cen-w64-xr/build/obj-firefox/xulrunner/installer'
make[1]: *** [all] Error 2
make: *** [package] Error 2
program finished with exit code 2
elapsedTime=23.215000
I think this is just a dupe of bug 661910.
Reporter

Updated

8 years ago
Blocks: 575912
Summary: Linking XPT files fails for Windows 64-bit → Linking XPT files fails for Windows 64-bit's XulRunner

Comment 2

8 years ago
Indeed.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 661910

Updated

Last year
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.