plugin-container crashes on startup of Fennec Aurora and Nightly on OSX 10.5

RESOLVED INVALID

Status

Firefox for Android Graveyard
General
P1
critical
RESOLVED INVALID
7 years ago
3 years ago

People

(Reporter: aakashd, Unassigned)

Tracking

({regression})

Firefox 7
Firefox 6
x86
Mac OS X
regression

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 541719 [details]
problem report generated by OSX 10.5

Build Id:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:7.0a1) Gecko/20110624 Firefox/7.0a1 Fennec/7.0a1 ID:20110624043628

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:6.0a2) Gecko/20110624 Firefox/6.0a2 Fennec/6.0a2 ID:20110624061725

Note: This was done with a new profile and an old profile. I don't see a crash on the 5.0b7 build, so its definitely a regression. I don't see any crash reports submitted via about:home either.

Steps to Reproduce:
1. Open Fennec Aurora or Nightly builds

Actual Results:
The plugin-container process will crash

Expected Results:
The plugin-container process does not crash and I can load pages.
(Reporter)

Updated

7 years ago
Summary: plugin-container crashes on startup of Fennec Aurora and Nightly 6/23 → plugin-container crashes on startup of Fennec Aurora and Nightly on OSX 10.5

Updated

7 years ago
Keywords: regressionwindow-wanted
tracking-firefox6: ? → -
tracking-firefox7: ? → -

Comment 1

7 years ago
This is presumably a regression from bug 564086.
Blocks: 564086
tracking-firefox6: - → ?
tracking-firefox7: - → ?
tracking-firefox6: ? → -
tracking-firefox7: ? → -
(Reporter)

Comment 2

7 years ago
Is a regression range still needed? At the very least it's within a ten day slot since 5.0b7 was built on 6/14 and these nightlies were built on 6/24
a regression range would still be very useful. Since Josh has a suspect in mind, testing the nightly build on either side of that landing would be most helpful.

Comment 4

7 years ago
Why? bug 564086 only landed for moz7...

Comment 5

7 years ago
The problem report attached here is for a plugin-container crash in the interpose dylib, but we shouldn't be running OOPP on MacOS 10.5 ever.

Comment 6

7 years ago
And this is also filed under Fennec, which is mightily confusing...
This looks like a regression from bug 621117.

Comment 8

7 years ago
That landed on 24-May. And even if so, I still don't understand this bug. Are we saying that desktop fennec on mac is broken? If so, I'm surprised it ever worked, since we really can't support child processes correctly on MacOS 10.5. I think this should be WONTFIX if this is about Fennec.
> we shouldn't be running OOPP on MacOS 10.5 ever.

This is what I thought, and I assumed it when writing my patch for bug
621117.

Is this in fact what's happening?  Does Fennec have a legitimate
reason to want to run plugins OOP on OS X 10.5.X?  Has Fennec been
doing this all along?

If the answer to all these questions is "yes", it'd be easy enough to
change my patch to never interpose libplugin_child_interpose.dylib
except when running on OS X 10.6 or above.
(In reply to comment #8)
> That landed on 24-May. And even if so, I still don't understand this bug.
> Are we saying that desktop fennec on mac is broken? If so, I'm surprised it
> ever worked, since we really can't support child processes correctly on
> MacOS 10.5. I think this should be WONTFIX if this is about Fennec.

OK.  I don't have any information to add wrt timing.  (Depending on what you mean by "correctly", we could have separate content processes on Mac, but we would obviously have the same problems with OOPP as on m-c tip.)

(In reply to comment #9)
> > we shouldn't be running OOPP on MacOS 10.5 ever.
> 
> This is what I thought, and I assumed it when writing my patch for bug
> 621117.
> 
> Is this in fact what's happening?  Does Fennec have a legitimate
> reason to want to run plugins OOP on OS X 10.5.X?  Has Fennec been
> doing this all along?
> 

plugin-container is used for content processes and plugin processes.  I asked that the interpose library not be used for non-plugin processes in 621117 but I see that didn't happen.
(All that said, I agree that it's not worth investing effort into OOP(anything) on 10.5 at the moment.)
> plugin-container is used for content processes and plugin processes.
> I asked that the interpose library not be used for non-plugin
> processes in 621117 but I see that didn't happen.

The reason it didn't happen is that you told me there currently isn't
any good way to do it.
(In reply to Chris Jones [:cjones] [:warhammer] from comment #11)
> (All that said, I agree that it's not worth investing effort into
> OOP(anything) on 10.5 at the moment.)

Based on this comment I'm removing the regressionwindow-wanted tag.
Keywords: regressionwindow-wanted

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.