"devicemanager.DMError: unable to connect to 10.250.49.29 after 5 attempts" should be treated as purple, not red

RESOLVED DUPLICATE of bug 660480

Status

RESOLVED DUPLICATE of bug 660480
7 years ago
5 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
Android mochitest-2 failure log, which was considered "busted"/red:
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1308946128.1308947406.6238.gz

The failure was:
{
======== BuildStep ended ========
======== BuildStep started ========
Reboot Device slave lost
=== Output ===
python /builds/sut_tools/reboot.py 10.250.49.29
 in dir /builds/tegra-042/test/build (timeout 1200 secs)
 watching logfiles {}
 argv: ['python', '/builds/sut_tools/reboot.py', '10.250.49.29']
 environment:
  PATH=/opt/local/Library/Frameworks/Python.framework/Versions/2.6/bin:/opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin
  PWD=/builds/tegra-042/test/build
  SUT_IP=10.250.49.29
  SUT_NAME=tegra-042
  VERSIONER_PYTHON_PREFER_32_BIT=yes
  VERSIONER_PYTHON_VERSION=2.6
  __CF_USER_TEXT_ENCODING=0x1F6:0:0
 closing stdin
 using PTY: False
connecting to: 10.250.49.29
reconnecting socket
unable to connect socket
reconnecting socket
unable to connect socket
reconnecting socket
unable to connect socket
reconnecting socket
unable to connect socket
reconnecting socket
unable to connect socket
/builds/tegra-042/test/build/../proxy.flg
reconnecting socket
unable to connect socket
Traceback (most recent call last):
  File "/builds/sut_tools/reboot.py", line 25, in <module>
    dm.getInfo('process')
  File "/builds/tools/sut_tools/devicemanager.py", line 1082, in getInfo
    data = self.verifySendCMD(['info ' + d])
  File "/builds/tools/sut_tools/devicemanager.py", line 139, in verifySendCMD
    return self.sendCMD(cmdline, newline, False)
  File "/builds/tools/sut_tools/devicemanager.py", line 166, in sendCMD
    raise DMError("unable to connect to %s after %s attempts" % (self.host, self.retrylimit))        
devicemanager.DMError: unable to connect to 10.250.49.29 after 5 attempts
program finished with exit code 1
elapsedTime=30.237428
=== Output ended ===
======== BuildStep ended ========
}

That's an infra problem, and should ideally be recognized as "status: exception" (purple) rather than busted/red.
That does know that it's an infra problem (and a problem that follows some other problem): see, e.g., the purple http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Aurora/1308965272.1308965392.21163.gz

The actual problem in your log was one buildstep above that, bug 660480, which does already know that it's the wrong color.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 660480
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.