Status

support.mozilla.org
Knowledge Base Software
RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: atopal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Since we don't have a Croatian localizer anymore and Croatian and Bosnian are so close to each other please forward the /hr locale to /bs.

Comment 1

7 years ago
It would be fine to transfer Croatian articles (93 articles) to Bosnian articles (1 articles).
(Reporter)

Comment 2

7 years ago
Yeah, I'd guess so. I contacted the former Croatian and now Bosnian localizer to ask about that.

Comment 3

7 years ago
According to the Serbian locale leader, this question is highly politic and might hurt the pride of Croatian people. So I am sure it is necessary.

Comment 4

7 years ago
this is not possible because hr and bs have different IT words for password, desktop, and a lot other words are different so this will only mess up our translations, why not to make some event in croatia to find new contributors

Comment 5

7 years ago
First of all, I am that former Croatian localizer. 

2nd, I dont understand why l10n hr is actually NOT added in here as it also matters and involves them. l10n hr also does fx as product.

3rd, people do understand majority but the problem is more how they will accept that croatian sumo actually is made on bs sumo.

4th, I joined because of that "pride".

5th, I am sure drivers will find some solution to bypass or reduce any possible negative impact this might have.

Cheers and good luck,
Edo
(Reporter)

Comment 6

7 years ago
To address the points here:

2. done.
3. I am to figure out what's best for Croatian users. I do get the national sensibility issue, but I thought that when Croatian users have a Firefox issue, they would be better served by understandable and up to date help articles than national pride.

But now I'm a bit lost. If Bosnian and Croatian have such a different wording wrt the IT words, it might be confusing indeed. Since I don't speak either language I need some help here to decide. There are basically two options in the absence of a locale leader for /hr:

1. Croatian users get outdated Croatian articles + up to date English articles
2. Croatian users get up to date Bosnian articles.

What do you guys think would serve Croatian users best?
(Reporter)

Comment 7

7 years ago
I changed the milestone for this so we can decide without any pressure.
Target Milestone: 2011-07-05 → 2011-07-19
(Reporter)

Comment 8

7 years ago
okay, sorry for the bugspam, but the first sentence for 3. should have been: "I am *trying* to figure out what's best for Croatian users."

Comment 9

7 years ago
Heh... We didn't know Edo moved to another language :)

I doubt this has anything with 'pride', but if you link Croatian to Bosnian it will only sound strange and people (in Croatia) would complain about bad translation. Languages are similar, but they aren't the same.

I'd rather suggest doing what is done for other languages, linking to English. It would be less confusing to have mixed English and Croatian, then Croatian and Bosnian; less surprises.

Comment 10

7 years ago
ok to make it clear it is not different in way that people from both countries can not understand it they can but sending all articles to Bosnian will mess Bosnian translations we will have 3 or 4 different words used for same thing and we in bosnian l10n don't want that and also bosnian users are unhappy to see words from croatian because for some of them it's complicated to find out what it mean really , there is a nice showcase for USB in bosnian it is  simple USB or memory stick , but if you look at croatian translations and usage they are using something like smart pen or something else which people here in Bosnia are handling like jokes , so I think it is good to say there is no finished local for Croantian if you want to finish it please register and contribute in l10n or if you can't help please use bosnian by clicking on next link , so croatian people get information that they need crew and if they don't want or can't help they can use bosnian without affecting bosnian users (with these croatian topics because they will confuse them how that  translation can be bosnian when it is croatian  ) but you wont make mistake if you forward users to  bosnian with informing them that they are forwarded there ,
I hope you understand what I want to say ,
bye

Comment 11

7 years ago
If I understand Ante:
* the hr SUMO keeps its 93 articles mainly translated by Edo, a Bosnian.
* Edo must start the bs SUMO from scratch.

Comment 12

7 years ago
I'm not suggesting anything for Bosnian. Majority of articles Edo did are grammatically correct, regarding Croatian language. I'm sure they aren't correct, regarding Bosnian language.

If you rename them to Bosnian, and then link Croatian to Bosnian, it would be plain - stupid. You would have bad Bosnian translation and good Croatian translation under bs/ :)

Worst thing you could do is rename hr/ to bs/, link hr/ to bs/ and have everything under bs/ translated to Bosnian. That would be regression for Croatian users. Edo did great work, but if he decided to translate articles in Bosnian, that doesn't mean all his previous translations were in Bosnian language.

Can't hr/ articles just be copied to bs/? I'm sure bs l10n team will find lots of things there that require editing and translation.

Comment 13

7 years ago
(In reply to comment #9)
> Heh... We didn't know Edo moved to another language :)
> 
I didnt move to another language but resigned completely from anything related to hr and kerim asked me to help them out since I am no longer related to hr and i accepted. yes, i know, there are differences between bosnian and croatian but kerim said he has someone to check it and make ready even on proper grammar before publishing.

Comment 14

7 years ago
(In reply to comment #11)
> If I understand Ante:
> * the hr SUMO keeps its 93 articles mainly translated by Edo, a Bosnian.
> * Edo must start the bs SUMO from scratch.

And scoobie, i am native croatian, just for the record. so am not bosnian :D

Comment 15

7 years ago
Kadir, lets cut a long story short as any discussion is nothing but a waste of time. Leave everything as it is. We shall translate everything from scratch due to grammar differences between Bosnian and Croatian language and to match the translations used in bs Firefox locale.

Thanks in advance ;)

Comment 16

7 years ago
Kerim are you on IRC somewhere? Cause I don't understand what's the problem. Bosnian translation, AFAIK, doesn't exist (http://support.mozilla.com/bs/). Croatian does (http://support.mozilla.com/hr/). How can the 'solution' be copy non-existing translation over existing translation? Cause that's how I understand this bug. I don't think explaining dropping (existing) Croatian localization is a 'waste of time'. There's no reason for you to start from scratch. You can use whatever Edo did and modify it for Bosnian language.
Maybe it would help to get people on Skype or the phone or IRC, something more synchronous, to have this discussion and figure it out?

For now, based on comment 15, I'm closing this as WONTFIX since there's no developer work to do. Please reopen if that changes at any point.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 18

7 years ago
Hey guys, thanks for all the input. It looks like we have a Happy End here :) Edo was successful in the search for a new Croatian locale leader, which means that we can keep updating the current Croatian localization. 

And I also got the message, /hr should never be forwarded to /bs. Thanks everyone!

Updated

7 years ago
Target Milestone: 2011-07-19 → ---
You need to log in before you can comment on or make changes to this bug.