Closed Bug 667177 Opened 10 years ago Closed 9 years ago

Fix first-tab, last-tab, beforeselected, and afterselected attributes that were broken by Panorama

Categories

(Firefox :: Tabbed Browser, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 585558

People

(Reporter: fryn, Unassigned)

Details

The first-tab, last-tab, beforeselected, afterselected attributes are there to make it easier for themes to style tabs, but Panorama broke these attributes by enabling hidden tabs to be arbitrarily distributed within a tab box.

We need to fix these for an edge case in the tab animations patch, since .tabbrowser-tab:only-child is no good anymore, since there could be tabs in other tab groups.
Bug 455694 doesn't strictly need this, so I'm removing it from the dependent bugs.

I'm unassigning myself, since I don't know how to do this without making all of the calculations O(number of tabs) slower, unless we do a rewrite of Panorama to place tabs in each group adjacent to one another.
Assignee: fryn → nobody
No longer blocks: 455694
Status: ASSIGNED → NEW
I can't think of a compelling enough reason at the moment for Panorama to group automatically its tabs together. (Indeed, I can't see at the moment how first-tab and last-tab would do better than O(number of tabs in largest group) with the change.)

Bug 577151 would likely make this easier to implement with less of a performance hit. Activity seems to be slow on that, though. Without it, it appears at worst to be some tab moving functions going from O(1) to O(n), which may or may not be significant. Other opinions?
No longer blocks: 585558
Depends on: 585558
No longer blocks: 582116
Status: NEW → RESOLVED
Closed: 9 years ago
No longer depends on: 585558
Resolution: --- → DUPLICATE
Duplicate of bug: 585558
You need to log in before you can comment on or make changes to this bug.