Sometimes, a ghost compose windows stays open after mail is sent

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
7 years ago
2 years ago

People

(Reporter: klint, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme?])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0
Build Identifier: TB5 Beta 2

I noticed that with TB5 latest builds (up to beta 2, did not test since), from time to time, an empty compose mail window stays open (and not clickable) after the actual mail has been sent.


Reproducible: Sometimes

Steps to Reproduce:
1. Respond to a mail (maybe also with new mail, but I'm not 100% sure)
2. Send the mail

Actual Results:  
Mail is sent but an *empty* compose window remains open, and cannot get focus (so cannot be closed).

Expected Results:  
No windows stays open after the mail is sent.

The only way to remove this window, is to open another mail and send it. Then both windows close properly.
I haven't been able to get the pattern for that.
Happens in Safe-mode as well.

Comment 1

7 years ago
Next time it happens see if anything appears in the error console.
(Reporter)

Comment 2

7 years ago
It just has happened again, and the error console shows nothing related to that event.
Same phenomenon as bug 347693, bug 380275, bug 547270?
See also bugs listed in depedency tree for bug 347693, please.

Updated

7 years ago
Whiteboard: [dupeme?]

Comment 4

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20110624 Thunderbird/5.0
Build Identifier: TB 5.0

Reproducible: Intermittent
Steps to Reproduce:
1. Reply to email
2. Send the mail
3. Have not seen with the sending of an original email

Actual Results:  
1. Reply email is sent. 
2. Empty Compose window opens in same exact screen coordinates as the Reply email.
3. Can obtain focus on the window by clicking on Windows task bar icon, but still can't close it.
4. Can remove this window by opening a new Compose window (doesn't need to be sent), or by closing Thunderbird completely.
5. No errors recorded to Error Console.

Expected Results:  
No new windows are spawned by sending Reply emails.

Comment 5

4 years ago
Still see this when using version 31 or newer?
Flags: needinfo?(klint)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(klint)
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.