Browser hang while reading https web page

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
18 years ago
11 years ago

People

(Reporter: nelson, Assigned: javi)

Tracking

1.0 Branch
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(I'm guessing about the product version and component portions of this
bug report, and the O.S.  The product version is whatever was shipped 
with NS6. Please revise as appropriate).

In an article in the newsgroup netscape.dev.ssl, 
"Dustin" <dustin@peoplewise.com> wrote:

  URL:   https://www.peoplewise.net/webclient/webapplicant.asp 

  Here's a test case to reproduce the problem without even having to have an 
  account on our system to authenticate successfully: 

  For the following input fields, enter random information: 
  Customer ID: <any numeric input> 
  Customer Password: <any alpha-numeric input> 
  User Name: <any alpha-numeric input> 
  User Password: <any alpha-numeric input> 

  In NS 4.7 and IE 5, an authentication error appears at the top of the same 
  login page. 

  In NS 6, the authentication error appears, but then hang...rest of the page 
  never makes it. 

  My server-side debugging shows that the HTTP POST arrives successfully, and 
  is complete (and decrypted successfully, etc.). The POST is processed as 
  normal, but some how, either the response never makes it back to Netscape or 
  it does but Netscape doesn't know what to do with it? This is really 
  difficult to tell, even when using a Network Monitor to see all the ingoing 
  and outgoing TCP/IP packets, because they are all encrypted!!! And the 
  problem only is reproducible using an SSL connection.

Comment 1

18 years ago
Nelson, Bugzilla handles only Mozilla-specific problems, not Netscape6 problems
unless they are reproducible in Mozilla latest nightlies. Could you please test
this for us? THanks alot!
I believe ALL PSM bugs get reported in bugzilla.
Can't reproduce on Mozilla {Build ID: 2001021820}
I think this is a dupe of bug 66419, and it does appear to be fixed. I couldn't 
test the other, though, due to the odd setup.

Comment 5

18 years ago
Worksforme. Reporter, please try the testcase again with a recent nightly build 
which contains PSM 2.0
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 6

18 years ago
Verified.
Status: RESOLVED → VERIFIED

Updated

14 years ago
Component: Security: PSM → Security: PSM
Product: PSM → Core

Updated

11 years ago
Version: psm1.4 → 1.0 Branch
You need to log in before you can comment on or make changes to this bug.