Cannot execute .php files

VERIFIED INVALID

Status

()

VERIFIED INVALID
7 years ago
7 years ago

People

(Reporter: camilleri.jon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

2.95 MB, application/octet-stream
Details
(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1) AppleWebKit/534.30 (KHTML, like Gecko) Chrome/12.0.742.100 Safari/534.30
Build Identifier: 5.0

Having copied wordpress files, installed FastCGI on my WinXP SP3 laptop I copied them to C:\Inetpub\wwwroot\wordpress, and, tried to navigate to http://127.0.0.1/wordpress/index.php, however, the browser prompts me to download the file, rather than having an option to run the .php script.

Screenshot at https://skydrive.live.com/?cid=B712073B3513EB8E&id=B712073B3513EB8E%211444&sc=documents&wa=wsignin1.0

This behavior seems to be consistent with other browsers, namely, IE8 and Google Chrome, however, it would be nice to have an option to run and execute PHP scripts locally.


Related links
1. Wordpress installation  at http://codex.wordpress.org/Installing_WordPress#Step_1:_Download_and_Extract

Reproducible: Always

Steps to Reproduce:
1. Extract a .php file on a pc which runs PHP 5
2. Browse to the .php file and try to open it with the browser



Actual Results:  
A popup window is displayed (https://skydrive.live.com/?cid=B712073B3513EB8E&id=B712073B3513EB8E%211444&sc=documents&wa=wsignin1.0)

Expected Results:  
PHP script and web applications would run in the browser
(Reporter)

Comment 1

7 years ago
Created attachment 542001 [details]
Wordpress

Updated

7 years ago
Component: Location Bar → General
Product: Firefox → Core
QA Contact: location.bar → general

Comment 2

7 years ago
The issue is with your web server. You need to configure it to send the correct data to the browser. You should probably seek assistance from the FastCGI or PHP folks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID

Comment 3

7 years ago
PHP runs in the webserver, not the browser. You need to configure your webserver to execute these files, and only send the output (as /text/html or text/plain) to the browser. Even if it's a local webserver.
verified
A browser supports only html, Javascript etc. but no server side scripting languages like PHP, ASP, CGI.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.