A bugfix for pixman ARM NEON optimizations (neon_composite_over_n_8888_0565_ca)

RESOLVED DUPLICATE of bug 746695

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 746695
6 years ago
6 years ago

People

(Reporter: Siarhei Siamashka, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:5.0) Gecko/20100101 Firefox/5.0
Build Identifier: 

There was an ARM NEON bug discovered and fixed recently in pixman: http://cgit.freedesktop.org/pixman/commit/?id=ece8d13bf77d050662bb9db9716576dabff37554

The problem only affects subpixel antialiased fonts rendering, which is not used by Mozilla on ARM unless I'm mistaken. So this bug might be not urgent.

Reproducible: Always
Thanks for the report. Sorry this took so long to triage. CC'ing concerned people on this.

I checked our copy of pixman and the bug is still present.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

6 years ago
Depends on: 638594
(Reporter)

Updated

6 years ago
Depends on: 746695
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 746695
You need to log in before you can comment on or make changes to this bug.