Incorrectly parsing mbox format?

RESOLVED WORKSFORME

Status

MailNews Core
Backend
RESOLVED WORKSFORME
17 years ago
9 years ago

People

(Reporter: Christos Cheretakis, Assigned: Navin Gupta)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
I'm attaching a screenshot of 'View source' of a mail saved in my local 'Sent'
folder.

The first line of the next message is shown as the last in this.

The screenshot was made with 2001012403 on linux
(Reporter)

Comment 1

17 years ago
Created attachment 23577 [details]
Capture of view source window

Comment 2

17 years ago
I think this is a line terminator issue - the size in the sent folder is wrong.
Status: UNCONFIRMED → NEW
Component: Mail Database → Mail Back End
Ever confirmed: true
(Reporter)

Comment 3

17 years ago
Not sure about that. When mozilla created the message that's being shown in the
screenshot, ie it was the last in the sent folder, selecting it produced a
strange message, but didn't write it down. I have now reorganized my sent
folder, so i can't check again.

When another mail was sent & written to sent folder, the message was never shown
again.

Comment 4

17 years ago
I meant to reassign this to Navin - doing so now. What I meant was the size of
the message as stored in the db was wrong. The error comes because we were
trying to read more bytes out of the file than were in the file. When you put
more messages in the file, you no longer get that error.
Assignee: bienvenu → naving

Comment 5

16 years ago
I have never seen this problem in any version (I guess starting with 0.9.4)
under Linux. Is this still happening?

pi
(Reporter)

Comment 6

16 years ago
I didn't even remember reporting this bug ;-) Never seen something similar,
because I've moved to IMAP.

Comment 7

16 years ago
resolving wfm, then.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.