Closed Bug 667380 Opened 11 years ago Closed 8 years ago

A crash that is unique, but happened on the same website for the past month.

Categories

(Core :: JavaScript Engine, defect)

5 Branch
x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: herbiedupree, Unassigned)

References

()

Details

(Keywords: crash)

Crash Data

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0

I have had various crashes related to the newer interface @ Yahoo! Mail. This one is unique and not previously reported.

Reproducible: Didn't try
Keywords: crash
Whiteboard: dupeme
Please post the crash id from about:crashes.
Version: unspecified → 5 Branch
d3e7b2e7-5e22-46cf-b3ce-e32582110626
https://crash-stats.mozilla.com/report/index/d3e7b2e7-5e22-46cf-b3ce-e32582110626

0 	mozjs.dll 	js::mjit::stubs::FixupArity 	js/src/methodjit/InvokeHelpers.cpp:270
1 	mozjs.dll 	js::mjit::EnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:683
2 	mozjs.dll 	CheckStackAndEnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:712
3 	mozjs.dll 	js::mjit::JaegerShot 	js/src/methodjit/MethodJIT.cpp:729
4 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:643
5 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:726
6 	mozjs.dll 	js::ExternalInvoke 	js/src/jsinterp.cpp:849
7 	mozjs.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:5153
8 	xul.dll 	nsXPCWrappedJSClass::CallMethod 	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1667
9 	xul.dll 	nsXPCWrappedJS::CallMethod 	js/src/xpconnect/src/xpcwrappedjs.cpp:586
10 	xul.dll 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:114
11 	xul.dll 	SharedStub 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:141
12 	xul.dll 	nsDOMEventListenerWrapper::HandleEvent 	content/events/src/nsDOMEventTargetHelper.cpp:65
13 	xul.dll 	nsEventListenerManager::HandleEventSubType 	content/events/src/nsEventListenerManager.cpp:1136
Crash Signature: [@ js::mjit::stubs::FixupArity(js::VMFrame&, unsigned int) ]
This looks like it might be a dupe of Bug 665838, which is also a bug from Herbie.
I just added another crash signature that is related to most all of the others of the past month +. 2nd line in crash sig file.
Crash Signature: [@ js::mjit::stubs::FixupArity(js::VMFrame&, unsigned int) ] → [@ js::mjit::stubs::FixupArity(js::VMFrame&, unsigned int) ] js::mjit::EnterMethodJIT(JSContext*, JSStackFrame*, void*, js::Value*)
Just reproduced this bug @ Yahoo Mail.
b150b762-2de0-4cb4-ae06-49b9a2110701
Assignee: nobody → general
Severity: normal → critical
Crash Signature: [@ js::mjit::stubs::FixupArity(js::VMFrame&, unsigned int) ] js::mjit::EnterMethodJIT(JSContext*, JSStackFrame*, void*, js::Value*) → [@ js::mjit::stubs::FixupArity(js::VMFrame&, unsigned int) ] [@ js::mjit::EnterMethodJIT(JSContext*, JSStackFrame*, void*, js::Value*) ]
Component: General → JavaScript Engine
OS: Windows NT → Windows 7
Product: Firefox → Core
QA Contact: general → general
Herbie, Bug 675727 is also about crashing with this signature at yahoo mail with Firefox 5 which has been fixed in Firefox 6. Have you been able to reproduce this crash with the most recent Firefox 9.0.1?
(In reply to Bob Clary [:bc:] from comment #7)
> Herbie, Bug 675727 is also about crashing with this signature at yahoo mail
> with Firefox 5 which has been fixed in Firefox 6. Have you been able to
> reproduce this crash with the most recent Firefox 9.0.1?

or current firefox version?
Flags: needinfo?(herbiedupree)
Whiteboard: dupeme → [closeme 2013-08-01]
I have not been able to replicate this error since early 2012. As far as I'm concerned, it's a closed matter.
Flags: needinfo?(herbiedupree)
(In reply to Herbie D from comment #9)
> I have not been able to replicate this error since early 2012. As far as I'm
> concerned, it's a closed matter.

Thanks for the confirmation.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2013-08-01]
You need to log in before you can comment on or make changes to this bug.