Intermittent timeout in browser/base/content/test/tabview/browser_tabview_bug587043.js | application timed out after 330 seconds with no output

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: Ehsan, Assigned: raymondlee)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1309167447.1309168663.22731.gz
Rev3 WINNT 5.1 mozilla-inbound opt test mochitest-other on 2011/06/27 02:37:27

TEST-START | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug587043.js
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug587043.js | application timed out after 330 seconds with no output
INFO | automation.py | Application ran for: 0:07:02.500000
INFO | automation.py | Reading PID log: c:\docume~1\cltbld\locals~1\temp\tmpumxx8npidlog
==> process 3372 launched child process 3860
INFO | automation.py | Checking for orphan process with PID: 3860
PROCESS-CRASH | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug587043.js | application crashed (minidump found)
(Assignee)

Comment 1

8 years ago
Posted patch v1Splinter Review
Assignee: nobody → raymond
Status: NEW → ASSIGNED
Attachment #549031 - Flags: review?(tim.taubert)
Comment on attachment 549031 [details] [diff] [review]
v1

Review of attachment 549031 [details] [diff] [review]:
-----------------------------------------------------------------

The problem with all those 330 timeouts is not really easy to solve. This kind of means that we're actually freezing the test mochitest framework so that the test runner gets no output for 330s. Alas, this won't be fixed by using showTabView(), etc. I really have no idea how to tackle this because actually (almost) all our [randomorange] bugs are 330s timeouts now.

https://bugzilla.mozilla.org/buglist.cgi?short_desc=330&resolution=---&resolution=DUPLICATE&status_whiteboard_type=allwordssubstr&query_format=advanced&status_whiteboard=%5Borange%5D&short_desc_type=allwordssubstr&component=Panorama&product=Firefox&list_id=876491

So there seems to be a pretty basic problem, in our code or somewhere else. I'd really appreciate if you can find out what's happening here but that'll need reproducable timeouts and some debugging...
Attachment #549031 - Flags: review?(tim.taubert)
Comment hidden (Legacy TBPL/Treeherder Robot)
Mass marking whiteboard:[orange] bugs WFM (to clean up TBPL bug suggestions) that:
* Haven't changed in > 6months
* Whose whiteboard contains none of the strings: {disabled,marked,random,fuzzy,todo,fails,failing,annotated,leave open,time-bomb}
* Passed a (quick) manual inspection of bug summary/whiteboard to ensure they weren't a false positive.

I've also gone through and searched for cases where the whiteboard wasn't labelled correctly after test disabling, by using attachment description & basic comment searches. However if the test for which this bug was about has in fact been disabled/annotated/..., please accept my apologies & reopen/mark the whiteboard appropriately so this doesn't get re-closed in the future (and please ping me via IRC or email so I can try to tweak the saved searches to avoid more edge cases).

Sorry for the spam! Filter on: #FFA500
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange]
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.