Privacy setting "When using the location bar, suggest: History" shows both History and Bookmarks in results

RESOLVED INVALID

Status

()

Firefox
Bookmarks & History
RESOLVED INVALID
7 years ago
5 years ago

People

(Reporter: George Glynn, Unassigned)

Tracking

5 Branch
All
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

I set the Privacy settings to "When using the location bar, suggest: History" and cleared all browser history, then started typing in the Location bar.


Actual results:

The Location bar incorrectly suggests items from bookmarks, behaving exactly as if "History and Bookmarks" was selected.


Expected results:

No suggestions should have been displayed.
Component: Location Bar → Bookmarks & History
OS: Other → Windows XP
QA Contact: location.bar → bookmarks
(Reporter)

Comment 1

7 years ago
Please don't change the component back to "Bookmarks & History", this is clearly a "Location Bar" problem. The Bugzilla description for the "Location Bar" component reads:

For bugs in the Firefox "Smart Location Bar" UI element, including the bookmark and history autocomplete matching behavior. 

Carefully note the last half of that sentence.
Component: Bookmarks & History → Location Bar
Mozilla/5.0 (Windows NT 5.1; rv:7.0a1) Gecko/20110627 Firefox/7.0a1

I don't get any suggestions in the Location Bar after clearing all the history.(Tools -> Clear recent history -> Everything -> Clear now).

Reporter, please can you confirm whether this issue still occurs using Firefox in safe mode and/or with a clean profile?
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Basic+Troubleshooting#w_8-make-a-new-profile
QA Contact: bookmarks → location.bar
(Reporter)

Comment 3

7 years ago
I exported my bookmarks to HTML, terminated Firefox, blew away places.sqlite, started Firefox, reimported my bookmarks, and cleared my recent history once more for good measure, and now it no longer suggests bookmarks when only "History" suggestions are configured. I also visited a bookmark, at which point it (correctly) began to show up in suggestions (as a history item), and after clearing history again, it (correctly) stopped showing up in suggestions.

Looks like it was corruption in places.sqlite, which I've probably had hanging around for over a year, so sorry for the bad report. Marking this bug Resolved - Invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID

Updated

7 years ago
Component: Location Bar → Bookmarks & History
QA Contact: location.bar → bookmarks

Comment 4

5 years ago
I can confirm being affected by the same issue, which was resolved by uninstalling FF and deleting the profile directory before reinstalling FF 26.0 (which was the previous installed version).

If relevant, FF had been upgraded from previous versions when it displayed the problem.
You need to log in before you can comment on or make changes to this bug.