Email update to MoJo challenge winners

RESOLVED FIXED

Status

RESOLVED FIXED
8 years ago
4 years ago

People

(Reporter: ben, Assigned: Jacob)

Tracking

Details

Attachments

(9 attachments, 4 obsolete attachments)

(Reporter)

Description

8 years ago
Created attachment 542217 [details]
Process update.rtf

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330




Expected results:

Please send this message to all MoJo challenge participants before eod Monday, 6/27. Cheers!
Challenge participants have been imported into BSD. You can now send an email using the "MoJo Challenge Sign-Ups" constituent group.
Assignee: nobody → jacobcandoit
(Assignee)

Comment 2

8 years ago
The the "MoJo Challenge Sign-Ups" constituent group was created by Ryan to consist of those who agree to the Learning Lab contract form that we are sending out to the winners, and subsequently the runner ups.

I've renamed the constituencies as follows

"MoJo Challenge Winners - (top 60 for LLab invitation)" - *import winnners there*

"MoJo Challenge Review List" - formerly called "MoJo Challenge Sign-Ups" where Paul imported challenge participants reviewed by panel

"Mojo Challenge Runners Up (those not in top 60)" - we need to contact them separately after we see who signs up to the LLab from the winners list
(Assignee)

Comment 3

8 years ago
also hold on before you import, there were some duplicate usernames in the top 60 I have to weed out and resend
(In reply to comment #3)
> also hold on before you import, there were some duplicate usernames in the
> top 60 I have to weed out and resend

I've already imported them (they take a while to merge into the constituent database). I believe BSD strips out duplicates anyway.
(Assignee)

Comment 5

8 years ago
OK I see them now, there's only 52 because of the dupes, so let me weed and resend.
(Assignee)

Comment 6

8 years ago
Created attachment 542312 [details]
Winners (65 people with a score of .5 or above)

After deleting out all the duplicates of users who submitted more than once (some users made top 60 multiple times) I now have a refined winners list.

Since there were several tie scores at .5 near the 60 person cutoff, I decided to include everyone with a .5 or higher which totals 65 people instead of coming up with an arbitrary tiebreaker

Phillip said it's okay to overshoot a little since we're expecting people to decline.

So Paul, please stick these into the BSD group "MoJo Challenge Winners - (top 65 for LLab invitation)"
(Assignee)

Comment 7

8 years ago
Created attachment 542317 [details]
"Runners Up" The remaining 70 with a score below .5

The remaining 70 with a score below .5  (to be imported into constituent group "Mojo Challenge Runners Up...")
(Assignee)

Updated

8 years ago
Attachment #542317 - Attachment description: The remaining 70 with a score below .5 → "Runners Up" The remaining 70 with a score below .5
(Assignee)

Comment 8

8 years ago
Created attachment 542319 [details]
final review sheet with dupes/winners/runners up separated

This is the final sheet. I weeded out the dupes, separated the winners and the runners up on different sheets.
(Assignee)

Comment 9

8 years ago
Created attachment 542326 [details]
.xls version of final review panel export - with dupes/winners/runners up separation
(Assignee)

Updated

8 years ago
Attachment #542319 - Attachment is obsolete: true

Comment 10

8 years ago
Paul: thanks for doing this. 

Jacob: is there something additional you need Paul to do, or do you now have all you need to send from BSD tomorrow?
(Assignee)

Comment 11

8 years ago
We need Paul to re-import the winners (from winners.xls file uploaded here) into the constituency titled "MoJo Challenge Winners..."

as well as import the runners up (from runners up.xls file uploaded here) into the consitutency titled "Mojo Challenge Runners Up..."

and if possible, it would be helpful to have a CSV of usernames/emails since I cannot access the individual accounts in BSD, I can only contact the entire constituency group, so when we trickle in Runners Up, I won't be able to do it one by one.

Comment 12

8 years ago
Jacob: could you please be more specific about what you need Paul to do? there is alot of detail here and it is not clear exactly which tabs you need imported.

Paul: can you do one more export/import for MoJo once Jacob has provided more detailed instructions? Thanks.

Comment 13

8 years ago
Jacob / all: our privacy policy doesn't allow us to send a CSV or use email directly as it puts user data outside our secure systems. We'll need to find a way to mail people one by one from BSD. 

Ryan can help work this out for the runners up, but that shouldn't hold us back on sending to the winners.
(Assignee)

Comment 14

8 years ago
Understood on the privacy policy. We'll cross that bridge later.

As far as the imports needed:

There are three files attached here

1. "Winners..." - nothing there but a list of drumbeat IDs for Paul to import into BSD "MoJo Challenge Winners" constituency

2. "Runners Up..." - again, just a vertical list of drumbeat IDs for Paul to import into the BSD "MoJo Runners Up" constituency

3. "final review panel export" which contains all the various tabs and such. We don't need that for the imports, it's just there in case anyone needs it.

Comment 15

8 years ago
Great. Much clearer now. Thanks.

Paul: can you please import the two files Jacob has flagged in the previous comment?
(In reply to comment #14)
> 1. "Winners..." - nothing there but a list of drumbeat IDs for Paul to
> import into BSD "MoJo Challenge Winners" constituency
> 
> 2. "Runners Up..." - again, just a vertical list of drumbeat IDs for Paul to
> import into the BSD "MoJo Runners Up" constituency

Both of these have been imported. Give it about ~15 min before the constituent records show up in BSD.
(Assignee)

Updated

8 years ago
Attachment #542326 - Attachment is obsolete: true
(Assignee)

Comment 17

8 years ago
There seems to be an error, just noticed that both the Winners group & Runners up group in BSD have 60 people in them, when it should be

Winners - 65
Runners up - 70

I can try and do a comparison to see who's missing, but I'd be comparing drumbeat IDs against emails and guessing a little which ones match...

Paul, do you know what's going on?

Comment 18

8 years ago
Wrong spreadsheet imported? It's the two above in this bug, right?
(Assignee)

Comment 19

8 years ago
Yes, I re-checked them, both have 65 & 70 entry rows in their respective places, you both see the same thing right?
Hmm, they're in the CSV but not in BSD. Seems like the import messed up. I'll manually add them and comment again when done.
Okay, there are now 65 winners and 70 in the runner up group.
(Assignee)

Comment 22

8 years ago
Created attachment 543069 [details]
mojo runners up group1 (.45 score)
(Assignee)

Comment 23

8 years ago
Created attachment 543070 [details]
mojo runners up group2 (.4 score)
(Assignee)

Comment 24

8 years ago
Created attachment 543071 [details]
mojo runners up group3 (.35 score)
(Assignee)

Comment 25

8 years ago
Created attachment 543072 [details]
mojo runners up group4 (.3 score)
(Assignee)

Comment 26

8 years ago
Created attachment 543073 [details]
mojo runners up group5 (.25 score)
(Assignee)

Comment 27

8 years ago
We're about 40 hours away from beginning the process of sending out runners up invites.

After some investigation, it seems the best method is to do them in blocks based on each subsequent scoring group.

I've broken down the remaining scoring groups into a separate .xls file for each group, containing a list of drumbeat usernames for Paul to import as a separate BSD constituency group for each file. (sorry Paul to get you involved again, but it's the only way, since I have no way to compare the emails of the main runners up group with the scores that I have next to their drumbeat usernames)

So "mojo runners up group1.xls" gets imported into a "mojo runners up group1" BSD constituency, "mojo runners up group2" gets imported into a "mojo runners up group2" constituency and so on.

So far we have invited 65 people (everyone with .5 and above) invited, so next is to invite the 17 people with a score of .45, followed by the 12 with a score of .4, etc. 

Let me know if there's any questions, I'll get the emails primed and scheduled for delivery in the meantime
(Assignee)

Comment 28

8 years ago
Created attachment 543355 [details]
runner up IDs_with score column

this file gives us the option to re-import all Runners up at once, and add a custom field based on score so I can send a mailer to groups based on their scoring bracket.
(Assignee)

Updated

8 years ago
Attachment #543355 - Attachment is obsolete: true
(Assignee)

Comment 29

8 years ago
Created attachment 543356 [details]
runner up IDs_with score column

Apologies, last file had the header column, I stripped this one for you, same deal as last one

"this file gives us the option to re-import all Runners up at once, and add a custom field based on score so I can send a mailer to groups based on their scoring bracket."
(Assignee)

Comment 30

8 years ago
Created attachment 543468 [details]
Runners Up IDs and Group/Score column for BSD
Attachment #543356 - Attachment is obsolete: true
New constituent group has been created in BSD.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.