Text link getting corrupted at bugzilla.redhat.org

RESOLVED WORKSFORME

Status

()

Core
XUL
--
trivial
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Brian 'netdragon' Bober, Assigned: Peter Trudelle)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(8 attachments)

(Reporter)

Description

17 years ago
Build 2001111904, Mozilla, Win2k

If you have questions about this then talk to me on irc. 

First go to this url.
Then resize the page so that it is not wide enough to see the perl logo. 
Scroll the page to the right so you can see the "bug pages" link at the bottom.

That is where the problem is. Now, scroll the page to the left and *SLOWLY* 
scroll it to the right. The slower you go, the more it gets corrupted.

You have to use the tab to thumb to scroll, not the right or left buttons.

The graphic appears to have vertical lines through it. It looks fine in IE.
(Reporter)

Comment 1

17 years ago
The problem occurs as the link is being uncovered.

Comment 2

17 years ago
Works fine on Linux build 2001012806

Comment 3

17 years ago
updating component
Assignee: asa → karnaze
Component: Browser-General → Layout
QA Contact: doronr → petersen
(Reporter)

Comment 4

17 years ago
Because of the restructering of the page, the page collapses. Now you have to 
make the browser frame about 150 pixels wide so that half the right scrollbar 
is covered and the whole bottom scrollbar is visible. If you scroll back and 
forth slowly, the "bug pages" should become corrupted. This is 100% 
reproducible on the Jan. 19th build if you do it correctly and slowly enough. 
Notice the words "bug pages" are all that become corrupted.
(Reporter)

Comment 5

17 years ago
Created attachment 24291 [details]
Screenshot
(Reporter)

Comment 6

17 years ago
Notice the Bugzilla words at the top don't appear correctly.
(Reporter)

Comment 7

17 years ago
Created attachment 24294 [details]
testcase
(Reporter)

Comment 8

17 years ago
Created attachment 24295 [details]
Screenshot of testcase
(Reporter)

Comment 9

17 years ago
see also bug 67529

Comment 10

17 years ago
Think you could try with a newer build?

Comment 11

17 years ago
hmm.. I'm not seeing this problem in the latest build (Feb 13th). Reporter,
please pull the latest build and try your steps again.

Comment 12

17 years ago
Since this problem is reproducing any longer, I'm changing to works for me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 13

17 years ago
Marking verified in the Feb 27th build.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 14

17 years ago
Sorry for not replying. Still having the problem. Screen shot to be attached. 
Build from 2/22.
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 15

17 years ago
Created attachment 26350 [details]
Testcase
(Reporter)

Comment 16

17 years ago
Notice - resizing the window slowly over the link does the same thing.

I recommend playing around with different size windows, etc. It is not 100% 
reproducible.
(Reporter)

Comment 17

17 years ago
I have tracked down what has caused the bug. It is when the page becomes too 
small for the vertical scrollbar to stay. If you notice on all those pictures, 
the vertical scrollbar was disappearing or disappeared. I don't know why on 
those builds the scrollbar was disappearing when the window was so big, but it 
was. Now, I have build 2001031008. Now, when you make the window really small, 
the scrollbars disappear - it needs to be as small as possible. When that 
happens, you can cause the error by dragging the mouse on the text anywhere 
above the "bug pages" link to make the page scroll to the right as _SLOWLY_ as 
possible and the mess up should appear. It also happens with the email text 
nearby too.
(Reporter)

Comment 18

17 years ago
Created attachment 27440 [details]
New testcase
(Reporter)

Comment 19

17 years ago
Created attachment 27441 [details]
Woops let me try again - new testcase
(Reporter)

Comment 20

17 years ago
Created attachment 27442 [details]
Screenshot of new testcase

Comment 21

17 years ago
Based on the steps provided I can reproduce this issue.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 22

17 years ago
Created attachment 28461 [details]
A screen shot of the issue

Comment 23

17 years ago
Scrollbars -> reassigned to XP toolkit.
Assignee: karnaze → trudelle
Component: Layout → XP Toolkit/Widgets
QA Contact: petersen → jrgm

Comment 24

17 years ago
worksforme win2k, build 20010411.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.