bump telemetry notification bar persistence

RESOLVED FIXED in mozilla9

Status

()

Toolkit
Telemetry
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: mossop, Assigned: glandium)

Tracking

Trunk
mozilla9
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox7+ wontfix)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Just restarted my nightly and saw the prompt to enable telemetry but it vanished before I could click it. I set the prompt pref to false and restarted and it did the same thing again.

I suspect this is because I restore my tabs on startup and the notification isn't surviving the page load.
(Reporter)

Updated

7 years ago
Blocks: 652657
Session store probably results in the persistence of 3 not being sufficient (zpao explained on IRC that it fires onLocationChange 3 times just to restore a tab).
What gavin said. That was to make switch to tab work in bug 599909.
An easy fix would be to just bump the number up more, to e.g. 6.
(Assignee)

Comment 4

7 years ago
Created attachment 542737 [details] [diff] [review]
Bump telemetry notification persistence to 6

As suggested by Taras, I attempted to use a doorhanger instead.
I'm however the UX is that good with a doorhanger (and I think geolocation suffers the same problem): the popup shows up, the user has the choice to either answer now, later, or learn more. In the latter case, the popup disappears, and the link is opened in a new windows. When the user is done reading the information, it's not entirely clear that he is expected to click on the icon to bring the popup back up again so that he can make his decision based on what he read (and it doesn't work with the default anchor icon, cf. bug 668150).
There, the way it currently works (open a new tab with the information, and display the notification) works IMHO better, but this is not possible with a popup notification since it would hide the very text we want the user to read.
So in the end, keeping it the current way, but bumping the persistence such that the notification doesn't instantly disappear seems the least worst.
Attachment #542737 - Flags: review?(gavin.sharp)
(Assignee)

Comment 5

7 years ago
Also, popup notifications only present one option which in the case of our question notification is not very helpful (this can be changed with bindings, but that seems a lot of complications to avoid using infobar notifications)
Comment on attachment 542737 [details] [diff] [review]
Bump telemetry notification persistence to 6

Did you test that this indeed solves the reported problem?
Attachment #542737 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 7

7 years ago
(In reply to comment #6)
> Comment on attachment 542737 [details] [diff] [review] [review]
> Bump telemetry notification persistence to 6
> 
> Did you test that this indeed solves the reported problem?

I can't reproduce the reported problem at all, so I can't test if this fixes it.
Perhaps we should investigate further, then. I just tried a simple restore with the prompted pref reset, and didn't see this. Perhaps it depends on having a large session to restore?
(Reporter)

Comment 9

7 years ago
I saw it with 2 app tabs, 3 normal tabs and I had 6 tabs in another panorama group
tracking-firefox7: --- → +

Comment 10

7 years ago
Any downside to just bumping it?
No downside, we can do that now while we investigate further.
Attachment #542737 - Flags: approval-mozilla-release?
Attachment #542737 - Flags: approval-mozilla-beta?

Updated

7 years ago
Attachment #542737 - Flags: approval-mozilla-release?
Attachment #542737 - Flags: approval-mozilla-release-
Attachment #542737 - Flags: approval-mozilla-beta?
Attachment #542737 - Flags: approval-mozilla-beta-

Updated

7 years ago
status-firefox7: --- → wontfix

Comment 12

7 years ago
Landed stopgap on m-c:

http://hg.mozilla.org/mozilla-central/rev/150ffa37c632

As well as aurora8:

http://hg.mozilla.org/releases/mozilla-aurora/rev/82893137d4b0

Should we close this out and file a fileup for the root issue?

Updated

7 years ago
Attachment #542737 - Flags: approval-mozilla-aurora+

Comment 13

7 years ago
and of course by fileup I mean followup, sigh.
followup is bug 691951
Assignee: nobody → mh+mozilla
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Depends on: 691951
Resolution: --- → FIXED
Summary: Telemetry prompt doesn't stay open long enough to click → bump telemetry notification bar persistence
Target Milestone: --- → mozilla9
You need to log in before you can comment on or make changes to this bug.