When the user is not logged in, he can still enter translation which end nowhere

RESOLVED WORKSFORME

Status

Webtools Graveyard
Verbatim
--
major
RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: Vito Smolej, Unassigned)

Tracking

({dataloss})

Trunk
x86
All
dataloss

Details

(Whiteboard: [better verbatim])

(Reporter)

Description

7 years ago
If you are not attentive and do not miss the Google translate and Copy source icons, you may end up translating until cows come home and losing it all one sentence at the time: the target text box allows entries alright, but they get dumped the moment you hit next.

Suggest a warning, when the user enters anything into the target text box. 

Would spare me 2-3 hours work (hard to believe right?) some time ago. 

Regards

Vito
(Reporter)

Updated

7 years ago
Duplicate of this bug: 655458

Comment 2

7 years ago
There is a patch in this upstream bug report that should address this problem:
http://bugs.locamotion.org/show_bug.cgi?id=1785

Hopefully one of the verbatim admins can apply the patch and we can see how that goes. In general, please report Pootle bugs in the upstream bug tracker unless if it is a configuration issue with the installation here at Mozilla specifically.

Comment 3

7 years ago
Friedel,

Would you please ping in this bug once the patch is in the regular pootle update so I can apply it?

Thanks.

Comment 4

7 years ago
I can try and remember, but we really are trying to use just one bug tracker for Pootle, and to use the Pootle mailing list for announcement of releases of Pootle :-) I'm sure you understand that we can't develop Pootle on all the bug trackers and mailing lists of projects that use Pootle.

Please reconsider applying this patch. This solves a problem specifically reported here by Vito, and which might be more common at Mozilla because of the default permissions on the server. We'll need some testing for the patch before we can put it in a release, and you are perfectly positioned to help the Pootle community in this way. It would be a pity to withhold a possible solution from the Mozilla localisers until we have time to do another Pootle release, although it is obviously your decision.
Friedel: I can apply it, but can you just diff it into a single patch please? Downloading each of them separately and extracting from bug comments will be PITA :(

Comment 6

7 years ago
Thanks for looking into this, Gandalf. It is actually just one patch with a few versions posted as comments. Sorry for being lazy. I uploaded the patch now as a single patch file in the bug.

Updated

7 years ago
Keywords: dataloss
OS: Windows XP → All

Comment 7

7 years ago
Zbigniew,

Have you already applied this?
Whiteboard: [better verbatim]
(Reporter)

Comment 8

7 years ago
... passing around the buck unassigned.

The problem still exists as described by me 3 months ago.

Updated

7 years ago
Severity: normal → major

Comment 9

6 years ago
Pootle 2.2 fixes this problem:

* The text input widget is disabled if you don't have rights
* The Next and Previous unit buttons are moved to the bottom right of the screen which might help indicate that they aren't translation submission buttons.

I'm marking this fixed.

Vito -> if you could validate this bug when we deploy the new Pootle server that would be great.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

6 years ago
Hi Dwayne:

Testing in the current version of Verbatim, using Affiliates SL (missing 76 segments) as a test case. Entering the pages unlogged. I press "Nicht "übersetzte Zeigen" for Messages.po (Explanation: I am in Germany, so it is a German locale

1. The first untranslated segment opens up. On a second look it is different fdrom the usual case. Top German(!), bottom English, both greyed, below a text field I can enter the translation and press Next.
2. Same situation on the second untranslated segment. Pressing next in this case drops out of the segments loop into the man page.

The two texts entered are nowhere to be seen, but compared to the possible damage before this is fine.

It is for sure a worksforme, if not 100% fixed - whats left of the problems is pretty much minor.
Resolution: FIXED → WORKSFORME

Comment 11

6 years ago
Vito -> Thanks for that.  A bit early though :)  Verbatim is still running Pootle 2.1, if you wouldn't mind testing this again when Pootle 2.2 is deployed.
(Assignee)

Updated

2 years ago
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.