If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Charset decoding fails when navigating Newsgroups

RESOLVED DUPLICATE of bug 660019

Status

Thunderbird
Folder and Message Lists
RESOLVED DUPLICATE of bug 660019
6 years ago
6 years ago

People

(Reporter: JoeS1, Unassigned)

Tracking

({qawanted})

Trunk
x86
Windows 2000
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
Sometimes, when navigating Newsgroups certain characters are not displayed properly.
IE Â instead of spaces.
I can reproduce this in TB6 and TB7 but not in TB5
(I'm not seeing anything specific to TB6 and TB7 that might have caused this so, it could be Core Gecko)

Step to reproduce: (Much easier when bug 226890 is finally resolved)

Go to the message indicated in the URL above
You should see the following in the text of that message:
"Privacy and Facebook don't mix.  You can't have both. "
Use the "B" key 4 times to navigate back in the thread.
Use the "F" key 4 times to navigate forward to the original post.
You should see the following text:
Privacy and Facebook don't mix.  You can't have both."

Using the "N" key often produces the same result.

Other messages in that thread that seem to produce similar results:
<AI6dnXAVq6I5Gp7TnZ2dnUVZ_oudnZ2d@mozilla.org>
"You’re the one dense."
<qaOdnfuM2_Ub65_TnZ2dnUVZ_oWdnZ2d@mozilla.org>
"I don't let the 10 meg fill up.  Since I don't...."

Some things that I have done in process of elimination, to no avail:
Disabled HTML5 parser
Disabled all the "Jits" one at a time "methodjit,tracejit,jitprofiling
Set disk cache to 0 bytes

While this is an ugly experience when using TB as a Newsreader, I think the issue might be more important in understanding why the same codebase (presumably), reacts differently between Gecko 5 and Gecko 6 and 7
tracking-thunderbird6: --- → ?
tracking-thunderbird7: --- → ?
Keywords: qawanted
That is ... interesting. If I tweak the Character Set encoding from the menu, it works... until I navigate away and come back. This doesn't appear to happen if I copy it into another folder, the copy appears to have the correct interpretation.

Comment 2

6 years ago
yeah, I think this is a dup. If it still happens with tomorrow's builds, please re-open
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 660019
tracking-thunderbird6: ? → ---
tracking-thunderbird7: ? → ---
You need to log in before you can comment on or make changes to this bug.