Closed Bug 667829 Opened 9 years ago Closed 9 years ago

No accesskey (keyboard shortcut) for Folder in Add Bookmark dialog

Categories

(SeaMonkey :: Bookmarks & History, defect)

All
Other
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.5

People

(Reporter: info, Assigned: ewong)

Details

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:5.0) Gecko/20110619 Firefox/5.0 SeaMonkey/2.2
Build ID: 20110619205802

Steps to reproduce:

Press Ctrl-D or choose Bookmarks > File Bookmark...



Actual results:

Notice there's no keyboard shortcut to jump to the Folder item in the "Add Bookmark" dialog.


Expected results:

There should be a keyboard shortcut for this. The one item in the dialog that you always need to change if you organize bookmarks is the Folder.

It looks like the fix may be as simple as adding an editBookmarkOverlay.folder.accesskey in comm-central/source/suite/locales/en-US/chrome/common/bookmarks/editBookmarkOverlay.dtd , e.g. to make 'r' the accesskey (F-o-l-d are all in use):

  <!ENTITY editBookmarkOverlay.folder.label                    "Folder:">
+ <!ENTITY editBookmarkOverlay.folder.accesskey                "r">
  <!ENTITY editBookmarkOverlay.foldersExpanderDown.tooltip     "Show all the bookmarks folders">
Whiteboard: [good first bug]
I'm confirming this, plus moving version to trunk. (2.2 is string-frozen).
(And taking this.)
Assignee: nobody → ewong
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Version: SeaMonkey 2.2 Branch → Trunk
Attachment #543569 - Flags: review?(neil)
(In reply to comment #0)
> It looks like the fix may be as simple as adding an
> editBookmarkOverlay.folder.accesskey in
> comm-central/source/suite/locales/en-US/chrome/common/bookmarks/
> editBookmarkOverlay.dtd , e.g. to make 'r' the accesskey (F-o-l-d are all in
> use):
Although to be fair you can't actually summon both the folder picker and the feed location in the same dialog.
Comment on attachment 543569 [details] [diff] [review]
Added accesskey (r) to Add Bookmark dialog.

"r" works, although I think we'd prefer "F" because it's a capital letter.
Attachment #543569 - Flags: review?(neil) → review+
(In reply to comment #3)
> (In reply to comment #0)
> > It looks like the fix may be as simple as adding an
> > editBookmarkOverlay.folder.accesskey in
> > comm-central/source/suite/locales/en-US/chrome/common/bookmarks/
> > editBookmarkOverlay.dtd , e.g. to make 'r' the accesskey (F-o-l-d are all in
> > use):
> Although to be fair you can't actually summon both the folder picker and the
> feed location in the same dialog.

You mean the Folder Picker and the Feed location are mutually exculsive?
So wouldn't that mean I can use the F accesskey?
Changed accesskey (r) to (F).
Attachment #543569 - Attachment is obsolete: true
Attachment #544993 - Flags: review?(neil)
Attachment #544993 - Flags: review?(neil) → review+
Keywords: checkin-needed
Comment on attachment 544993 [details] [diff] [review]
Added accesskey (F) to Add Bookmark Dialog [Checked in: Comment 7]

http://hg.mozilla.org/comm-central/rev/31ef6d035561
Attachment #544993 - Attachment description: Added accesskey (F) to Add Bookmark Dialog → Added accesskey (F) to Add Bookmark Dialog [Checked in: Comment 7]
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Flags: in-testsuite-
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [good first bug]
Target Milestone: --- → seamonkey2.5
You need to log in before you can comment on or make changes to this bug.