Firefox crashes in CD3D10Resource::CGdiInterop::GetDeviceBitmapDC due to HWA + specific driver version(s) Lenovo laptops

RESOLVED WORKSFORME

Status

()

Core
Graphics
--
critical
RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: Tommie Van Mechgelen, Unassigned)

Tracking

({crash})

5 Branch
All
Windows 7
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

On a few pc's we are experiencing crashes when upgrading to firefox 5.  We have reinstalled one of the pc's multiple times.  But after a few moments of usage, firefox 5 starts to crash.  This happens when opening a webpage or reading a webpage or even just clicking the firefox menu and waiting for a few seconds.  There are no addons installed.  The pc has been fresh installed and is from Lenovo.

Please see the crash reports:
https://crash-stats.mozilla.com/report/pending/e218d850-869f-462a-a6fa-0fb6e2110624
http://crash-stats.mozilla.com/report/index/bp-8a81df25-404a-464a-8651-eaa8f2110624
http://crash-stats.mozilla.com/report/index/bp-a852bb36-8b46-4596-a262-d26cc2110624
http://crash-stats.mozilla.com/report/index/bp-918bb9b9-38c3-4ab2-b73c-7936b2110624


Actual results:

Firefox crashes.


Expected results:

Firefox should not crash.

Comment 1

7 years ago
Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

Please post the graphics section from about:support
Crash Signature: [@ @0x0 | CD3D10Resource::CGdiInterop::GetDeviceBitmapDC(CD3D10Device*, int) ]
Keywords: crash, crashreportid
_After_ you posted the graphic card driver section from about:support you should upgrade your graphic card drivers. Disabling the hardware acceleration under tools/options/advanced/general should be a workaround if a new graphic card driver doesn't help.
Component: General → Graphics
Product: Firefox → Core
QA Contact: general → thebes
(Reporter)

Comment 3

7 years ago
Dear,

in safe mode the crashes do not occur!

Here is the output from about:support.  I will test the disabling of hardware accel in a moment.

Adapter Description ATI Mobility Radeon HD 545v 
Vendor ID1002
Device ID9553
Adapter RAM512
Adapter Driversaticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Driver Version8.761.0.0
Driver Date7-27-2010
Direct2D Enabledtrue
DirectWrite Enabledtrue (6.1.7601.17563, font cache n/a)
WebGL RendererGoogle Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.611)
GPU Accelerated Windows1/1 Direct3D 10
(Reporter)

Comment 4

7 years ago
Dear,

the problem went away when the hardware accel is disabled.

Comment 5

7 years ago
Did you update your graphics card driver? http://support.amd.com/us/gpudownload/windows/Pages/radeonmob_win7-64.aspx
(Reporter)

Comment 6

7 years ago
Hi,

I can confirm that the problem is resolved by installing the latest graphics card driver mentioned above...

The bad thing is that the problem is caused by the driver lenovo is spreading through their lenovo update system.  

As we now have all our users with the same problem because the updates were installed through the lenovo system.

I will install the updated driver manually on all our pc's.

Thanks for you help.

Comment 7

7 years ago
Matti -> What is the right resolution here? Do you nominate a driver for the blacklist?
I'm not sure, a developer should decide if we should block this driver. Given that this seems to be the default driver for Lenovo we should consider it.
Will look at that next week, ping me if I forget. I will need to see the contents of the Graphics section in about:support.
>I will need to see the contents of the Graphics section in about:support.
look at comment#3
Yup, we should probably blacklist this. This is GDI interop so probably related to some of the plugin code. I doubt IE9 will suffer from it but I'd be interested to know.

Comment 12

6 years ago
Benoit, ping re comment 9. I ran across this after seeing a Q&A about problems with Firefox and a Lenovo laptop.

Kev, if Lenovo is shipping bad drivers can we reach out to them?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

6 years ago
Severity: normal → critical
OS: Other → Windows 7
Summary: Firefox crashes after a minute on a fresh installed pc. → Firefox crashes in CD3D10Resource::CGdiInterop::GetDeviceBitmapDC after a minute on brand new Lenovo laptops

Updated

4 years ago
Keywords: crashreportid
Summary: Firefox crashes in CD3D10Resource::CGdiInterop::GetDeviceBitmapDC after a minute on brand new Lenovo laptops → Firefox crashes in CD3D10Resource::CGdiInterop::GetDeviceBitmapDC due to HWA + specific driver version(s) Lenovo laptops

Updated

2 years ago
Crash Signature: [@ @0x0 | CD3D10Resource::CGdiInterop::GetDeviceBitmapDC(CD3D10Device*, int) ] → [@ @0x0 | CD3D10Resource::CGdiInterop::GetDeviceBitmapDC(CD3D10Device*, int) ] [@ @0x0 | CD3D10Resource::CGdiInterop::GetDeviceBitmapDC ]
Mass resolving WFM: signature(s) hasn't(/haven't) reported in past 28 days.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.