"Could not chdir to home directory : No such file or directory" when trying to connect to Hg

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
RESOLVED FIXED
7 years ago
3 years ago

People

(Reporter: Aki Laaksovirta, Assigned: phong)

Tracking

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:2.0.1) Gecko/20110608 Firefox/4.0.1 SeaMonkey/2.1
Build ID: 20110608020727

Steps to reproduce:

I get a following error message evfery time when I try to do anything that requires connecting to hg.m.o, for example with hg outgoing.

remote: Could not chdir to home directory : No such file or directory
remote: You do not have a valid mercurial account here!
abort: no suitable response from remote hg!

I have added myself in ~/.ssh/config with the following information:

Host hg.mozilla.org
User akilaa@wippies.fi

When I modify ~/.ssh/config in the following way:

Host hg.mozilla.org
User akilaa

the error message changes into:
Permission denied (publickey,gssapi-with-mic).
(Assignee)

Comment 1

7 years ago
"remote: You do not have a valid mercurial account here!"

Have you had a HG account before?
(Reporter)

Comment 2

7 years ago
No. I have had an Hg account since last week.
(Assignee)

Comment 3

7 years ago
Do you have the bug number for your HG account request.  I see the HG bit in LDAP is not enable for you.  Once I see that, I can enable that for you and you should be squared away.
(Reporter)

Comment 4

7 years ago
The bug number is 614791.
(Reporter)

Updated

7 years ago
Blocks: 667374
(Assignee)

Comment 5

7 years ago
enabled the HG bit for you.
Assignee: server-ops → phong
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.