news messages that have lines that start with ".foo" get displayed as "..foo"

VERIFIED FIXED

Status

MailNews Core
Backend
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

post a news message, with the body:

.foo

when you go and read the message on the news server, you'll see

..foo

I know if you post an message with a line like this:

.

we should turn that into 

..

but only if the line only contains "." and nothing else.

this might be a duplicate, I vaguely remember a bug like this.
I think I have a patch.  testing it now.  if I'm right, the bug is in
nsMsgProtocol.cpp
I'm wrong, it's not on send it's on display.  still looking...
I think I've got the fix.  a problem with nsNNTPProtocol.cpp

testing it now...
cool, I have a fix.  patch coming soon.
Status: NEW → ASSIGNED
updating summary, removing mscott.
Summary: news messages that have lines that start with ".foo" get posted as "..foo" → news messages that have lines that start with ".foo" get displayed as "..foo"
see http://lxr.mcom.com/nova/source/lib/libnet/mknews.c#5303

we used to do this in 4.x, but that code never got brought over.
*** Bug 61799 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
sr=bienvenu
fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
QA Contact: esther → stephend
VERIFIED.  This is working as describe on Windows 2000 build 2001012904, Mac
2001012908 and Linux 2001012908.

All posted .foo entries show up in the NG as .foo, instead of ..foo.

Status: RESOLVED → VERIFIED
some info on the problem.

section 3.10.1 of rfc 977:
   A single period (".") on a line indicates the
   end of the text, with lines starting with a period in the original
   text having that period doubled during transmission.

so we were correctly adding the extra ".", but not removing it upon reading it.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.