Autostart message filters for rss feeds (feature request)

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: justas.mob.90, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 2011061500

Steps to reproduce:

1. Create "RSS News & Blogs" account.
2. Create new filter.
3. Update RSS feeds or wait auto-update RSS channel


Actual results:

Filters not work automatically for RSS feed.


Expected results:

I would like to see the automatic processing of new rss entries (with filters Thunerbird).
What would you like to do with the filters ? what is not working ? please expand, because for now I don't understand what your request is about.

Comment 2

7 years ago
> What would you like to do with the filters ?

Scheme: 
RSS feed is automatically updated → received new entries → filters run automatically (sort, move to special folder, run action, etc.)
Same it is logical, whether that?

But now I should apply filters manually ("run filters in selected folder"). This is bad.
Status: UNCONFIRMED → NEW
Component: Search → Filters
Ever confirmed: true
Product: Thunderbird → MailNews Core
QA Contact: search → filters
Anything in the filter logs hinting I why it's not working ?
Status: NEW → UNCONFIRMED
Ever confirmed: false

Comment 4

7 years ago
Nothing.
But this function wasn't and in prior versions (for example in 4.0)! Speech about an automatic filtration RSS feeds without involvement of the person- in the same way, as it is implemented for e-mail. Nothing more...

Comment 5

7 years ago
I was mistaken, in log there were records- when receiving new RSS entries automatically.

But it is difficult to check: the filters wasn't applied to subfolders, when I select menu item "Run filters in selected folder" in root folder.

Comment 6

6 years ago
this works for me in Tb17.  creating a filter in a feeds account, adding a rule like If Subject contains "thunderbird" Move to some folder, and getting new messages on the folder (feed url=http://planet.mozillamessaging.com/rss20.xml) will auto move the matches.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Updated

6 years ago
Duplicate of this bug: 432841
You need to log in before you can comment on or make changes to this bug.