Sentence not precise enough - caption of option about deletion of messages "to recover disk space..."

RESOLVED DUPLICATE of bug 582170

Status

--
minor
RESOLVED DUPLICATE of bug 582170
7 years ago
2 years ago

People

(Reporter: goofy.bugzilla, Assigned: goofy.bugzilla)

Tracking

(Blocks: 1 bug, {ux-userfeedback})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Assignee)

Description

7 years ago
Created attachment 542758 [details] [diff] [review]
more words to be more precise

Among imap account parameters this sentence
"To recover disk space, old messages can be permanently deleted, both local copies and originals on the remote server."
should probably be completed so that users are really aware the distant copy will be deleted too.
My suggestion in the attached patch
"To recover disk space, old messages can be permanently deleted, both local copies and originals on the remote server will be deleted."

I reckon it is redundant, but when translating exactly (ie without final verb redundancy) in French we hit the case of a user discovering his distant messages vanished.
(of course the French translation is to be fixed very soon)
(Assignee)

Updated

7 years ago
Attachment #542758 - Flags: review?(bwinton)
Assignee: nobody → GoofyFr
Status: NEW → ASSIGNED
Keywords: ux-userfeedback
Comment on attachment 542758 [details] [diff] [review]
more words to be more precise

Review of attachment 542758 [details] [diff] [review]:
-----------------------------------------------------------------

I apologize for the length of time it took to get to this review.

I think we can get a better wording with a couple more tries…

I've offered a couple of suggestions below that attempt to remove the redundancy.  If you think it's important to mention it twice, then I think I would break the label up into two sentences, like:

To recover disk space, old messages can be permanently deleted.  Both local copies and the originals on the remote server will be removed if you choose this option.

But I worry about that being too long…

::: mail/locales/en-US/chrome/messenger/folderProps.dtd
@@ +58,4 @@
>  <!ENTITY daysOld.label "days old">
>  <!ENTITY message.label "messages">
>  <!ENTITY retentionCleanup.label "To recover disk space, old messages can be permanently deleted.">
> +<!ENTITY retentionCleanupImap.label "To recover disk space, old messages can be permanently deleted, both local copies and originals on the remote server will be deleted.">

How do you feel about something like:

To recover disk space, old messages (both local copies and originals on the remote server) can be premanently deleted.

?

Or:

To recover disk space, old messages can be permanently deleted from both the local computer and the remote server.

?
Attachment #542758 - Flags: review?(bwinton) → review-
I also wonder if this is related to bug 286888?

Comment 3

7 years ago
> How do you feel about something like:
> 
> To recover disk space, old messages (both local copies and originals on the
> remote server) can be premanently deleted.

I prefer this version.

> I also wonder if this is related to bug 286888?
In my opinion, the two bugs are differents. This one is about a clarification of a setting, bug 286888 is about a simplification of the UI, which could maybe hide some advanced settings (like compaction).

Comment 4

7 years ago
(In reply to comment #0)
> Created attachment 542758 [details] [diff] [review] [review]
> more words to be more precise
> 
> Among imap account parameters this sentence
> "To recover disk space, old messages can be permanently deleted, both local
> copies and originals on the remote server."

I think this is clear enough, as far as my Englih goes.

> should probably be completed so that users are really aware the distant copy
> will be deleted too.
> My suggestion in the attached patch
> "To recover disk space, old messages can be permanently deleted, both local
> copies and originals on the remote server will be deleted."
> 
> I reckon it is redundant, but when translating exactly (ie without final
> verb redundancy) in French we hit the case of a user discovering his distant
> messages vanished.
> (of course the French translation is to be fixed very soon)

IMO, it's up to each language team to make messages unambigous. If the original is unambigous in English, then for English, that goal is reached. If translating that string literally results in ambiguity in another language, then it's that other language team's job to polish the text. Don't be just a mere translator – interpret! :)

I think we should let English speakers decide which wording suits them best. It's their call, not ours.

Updated

7 years ago
Assignee: GoofyFr → nobody
Component: General → Account Manager
QA Contact: general → account-manager

Updated

7 years ago
Assignee: nobody → GoofyFr
What worries me much more is that we seem to have lost the distinction between pop and imap. This is what I see in the settings for my *POP3* account:

To recover disk space, old messages can be permanently deleted, including originals on the remote server.

Does this really mean that on a *Pop3* account, enabling that setting will remove my originals from the server? (I hope not..., but I can't test...) How does that interact with that other setting I have, "Leave messages on server" (for good, with no exceptions)?
(In reply to Thomas D. from comment #5)
ftr, that's on TB8.

Comment 7

7 years ago
This patch seems not to be applied yet. So the string was there even before the patch, which can be seen in the patch in the removed ('-') lines.

So the setting probably means what it says on POP3 too. Usually the messages already aren't on the server anyway, when this purging kicks in and deletes them locally. (Hopefully the setting "keep messages on server for at most X days" takes precedence, but I haven't tested.)

Updated

7 years ago
Severity: normal → minor
Summary: Sentence not precise enough - about messages deletion to save space disk → Sentence not precise enough - caption of option about deletion of messages "to recover disk space..."

Updated

7 years ago
Blocks: 746350

Comment 8

7 years ago
If this is l10n sensitive you'll need to change the entity names and make corresponding changes for the suite/locales part. Also see bug 746350.

Comment 9

7 years ago
(In reply to Thomas D. from comment #5)
> "To recover disk space, old messages can be permanently deleted, including
> originals on the remote server."
> Does this really mean that on a *Pop3* account, enabling that setting will
> remove my originals from the server?

I didn't have access to a POP account either when working on bug 410597 thus couldn't test and had to rely on actual POP users telling me otherwise.

Either way, any clarifications made for the IMAP label (where I don't think that attachment 542758 [details] [diff] [review] adds much given that the context within that specific description at least appears to be clear; it's rather the mix of local and remote items with synchronization vs. retention causing the potentialconfusion, as expanded on in bug 746350 comment #6) should be made for POP accounts as well to keep things consistent.

Comment 10

5 years ago
I remain an ardent fan of Mozilla (I have a Firefox ZTE Open in my pocket and a Peek on order), but this 'feature' has caused me more distress than all other bugs or features of all Mozilla products that I have used.

I have a basic philosophy that communication is unsuccessful if the target audience fails to understand.  

I apparently had a moment where I exercised very poor comprehension, but Thunderbird still did something that has scarred me (lightly).  I agree that the words "both local copies and originals from the remote server" are quite clear.  However, I must have skimmed over those after reading the other words ("Disk Space" and "To save disk space, downloading messages... and keeping *local* copies..." (emphasis added) down to the list of options that reads "Delete messages more than [value] days old". 

Like others, I wiped my server's emails with this option (just last week).  I'm updating Thunderbird when it requests (at 17.0.8 today) so this is still something of an issue.  I had recently switched from a 3rd party server to my own IMAP server so I *only* lost the last two months of emails, but it still felt pretty terrible.

Here is what I (idiotically) did:
1. I set up my personal email server from work in an attempt to access my calendar using the mail server authentication. 
2. I tried to delete local emails only
3. In a moment of tremendous laxness, I changed the compacting settings to compact messages more than 1 day old (the minimum)
4. Some number of minutes later I invoked the compact option (initially thinking I had deleted only local messages)
5. I realized I had deleted almost every message from my IMAP server and got the sinking feeling

Not certain this is the best place (still looking through bugs), but in addition to improving the wording I would love to see a feature where Compact first tells you how many messages will be deleted and says from server and from local folders.  In this vein, although I have never contributed to Thunderbird this may be something I'm interested in trying to hack together.  Would that be useful?

PS The calendar issue that led me down that path was 'solved' insofar as I gave up on hosting my own email in order to get Google's protection of my data (they archive my messages even if an IMAP client tries to delete them) and it came with a Calendar that Lightning talks to quite nicely.

Comment 11

5 years ago
Created attachment 799673 [details]
Message Synchronizing options.png

For reference, I have attached the 17.0.8 version of the "Message Synchronizing" dialog...

Comment 12

5 years ago
I remain an ardent fan of Mozilla (I have a Firefox ZTE Open in my pocket and a Peek on order), but it may be possible that this 'feature' caused me more distress than any other bug or feature I ever recall encountering.  Like others, I wiped my server's emails with this option (just last week).  I'm updating Thunderbird when it requests (at 17.0.8 today) so this is still something of an issue.  I had recently switched from a 3rd party server to my own IMAP server so I *only* lost the last two months of emails, but it still felt pretty terrible.

I have a basic philosophy that communication is unsuccessful if the target audience fails to understand.  You can perhaps convince yourself that Thunderbird is aimed at a more [insert various adjectives] audience, but I recommend Thunderbird to my less [insert various adjectives] family members or colleagues all the time.

In hindsight, I see that I overlooked critical information, but it was still very painful when Thunderbird efficiently deleted all of my messages without confirmation dialog.  I agree that the words "both local copies and originals from the remote server" are quite clear.  However, I must have skimmed over those after reading the other words ("Disk Space" and "To save disk space, downloading messages... and keeping *local* copies..." (emphasis added) down to the list of options that reads "Delete messages more than [value] days old".   These are shown in the screen capture I just uploaded. 

Here is what I (idiotically - in hindsight) did:
1. I set up my personal email server from work in an attempt to access my calendar using the mail server authentication. 
2. I tried to delete local emails only
3. In a moment of tremendous laxness, I changed the compacting settings to compact messages more than 1 day old (the minimum)
4. Some number of minutes later I invoked the compact option (initially thinking I had deleted only local messages)
5. I realized I had deleted almost every message from my IMAP server and got the sinking feeling

---

Having expressed my frustration, I would like to know: what can I do to help improve this?  I would like for nobody to ever experience what I did (again).

For instance, rather than trying to further improve the wording, perhaps a feature where Compact first tells you how many messages will be deleted and says from server and from local folders.  I might be interested in trying to hack something like that together.  Would that be useful?

---
PS The calendar issue that led me down that path was 'solved' insofar as I gave up on hosting my own email in order to get Google's protection of my data (they archive my messages even if an IMAP client tries to delete them) and it came with a Calendar that Lightning talks to quite nicely.

Comment 13

5 years ago
After posting the comment the second time, failing to find it (again), and then locating the last comment button and realizing I posted twice, I'm revising my opinion of myself.  

It appears that in recent years I have slid from above average to well below average in technology and/or comprehension...   Nonetheless, even if it is only incompetent users (read: like me) who are deleting their messages, I am interested in helping reduce the likelihood or frequency.

Comment 14

5 years ago
Created attachment 799688 [details]
One way of emphasizing this

Instead of just trying to make the text super-clear, we could add some formatting to emphasize that this is a potentially-dangerous feature and that you should pay attention when messing with it. See the attached image for a rough example.
Attachment #799688 - Flags: ui-review?(bwinton)
Comment on attachment 799688 [details]
One way of emphasizing this

This is much clearer, and I like that it's very in-your-face.
But, I think we should mention the remote server first, to give it a higher chance of catching the eyes of people who skim the text.

ui-r=me with that change.
Attachment #799688 - Flags: ui-review?(bwinton) → ui-review+

Comment 16

2 years ago
Can one of you finish this off?  (Jean-Bernard seems to be gone, no response to PM)
And then we can tackle bug 746350
Flags: needinfo?(rsx11m.pub)
Flags: needinfo?(acelists)

Comment 17

2 years ago
Didn't we already change that texts in other bug since this bug was filed?

Yes, in the second block of options, choosing anything other than "don't delete any messages" will now pop up a warning (that it is really on server and local). Is there anything more to do?
Flags: needinfo?(acelists) → needinfo?(goofy.bugzilla)

Comment 18

2 years ago
Yeah, bug 582170. Forgot about that.  So this is done.  bug 746350 too?
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(rsx11m.pub)
Flags: needinfo?(goofy.bugzilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 582170
You need to log in before you can comment on or make changes to this bug.