compacting a folder deletes folder file

VERIFIED FIXED

Status

MailNews Core
Backend
--
critical
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: Oliver Klee, Assigned: Bienvenu)

Tracking

({dataloss})

Trunk
x86
Windows 2000
dataloss

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

776.63 KB, text/plain
Details
150.26 KB, application/octet-stream
Details
(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; m18) Gecko/20010125
BuildID:    2001012504

If I compact a folder, Mozilla sometimes compacts it very radically by deleting
the folder!

Reproducible: Sometimes

Steps to Reproduce:
1. Back up your Mozilla profile.
2. Select a folder (I'll attach the folder + msf file I used).
3. Compact the folder.
4. Repeat 2.-3. until you get an error #80520012 on selecting the folder (you
might have to try a few times).
5. Take a seat, hold fast.
6. Have a look at your profile directory ...

Actual Results:
1. Error #80520012, and
2. The file for the mail folder is gone from my disk. A new .msf file is created.

Expected Results:
1. No errors, and
2. No dataloss.
(Reporter)

Comment 1

17 years ago
Created attachment 23652 [details]
mail folder
(Reporter)

Comment 2

17 years ago
Created attachment 23653 [details]
corresponding .msf file

Updated

17 years ago
QA Contact: esther → sheelar

Comment 3

17 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

17 years ago
taking from scott.
Assignee: mscott → bienvenu
(Reporter)

Comment 5

17 years ago
Adding dataloss keyword.
Keywords: dataloss

Comment 6

17 years ago
Maybe this is related:
I tried compacting a POP-folder, folder size 5672960 bytes, folder.msf 8435
bytes, nothing happened after this operation, file sizes remained the same, but
I got a new nstmp and nstmp.msf-file in the mail folder, with nstmp 5647734
bytes, and nstmp.msf 7672 bytes. nstmp-files were not deleted upon regular exit
of the application.
Build: 2001020704, Win2000

Comment 7

17 years ago
If this has to do with "nstmp" file this may have been fixed. See #68875

Comment 8

17 years ago
Navin,
fyi -Bug 68875 has been reopened.  

Comment 9

17 years ago
Navin,
This bug was reopened because of bug 68875.  Now that 68875 is fixed this bug 
also should be marked fixed. I have not see folder getting deleted while 
compacting folder on 2001-03-29-06. 
(Assignee)

Comment 10

17 years ago
ok, marking fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 11

17 years ago
verified this bug while verifying bug 68875.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.